summaryrefslogtreecommitdiff
path: root/dev-util/bazel/bazel-0.24.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /dev-util/bazel/bazel-0.24.1.ebuild
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'dev-util/bazel/bazel-0.24.1.ebuild')
-rw-r--r--dev-util/bazel/bazel-0.24.1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-util/bazel/bazel-0.24.1.ebuild b/dev-util/bazel/bazel-0.24.1.ebuild
index 1bd189ee41cc..b81e83d2dc79 100644
--- a/dev-util/bazel/bazel-0.24.1.ebuild
+++ b/dev-util/bazel/bazel-0.24.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -43,8 +43,9 @@ bazel-get-flags() {
}
pkg_setup() {
- echo ${PATH} | grep -q ccache && \
+ if has ccache ${FEATURES}; then
ewarn "${PN} usually fails to compile with ccache, you have been warned"
+ fi
java-pkg-2_pkg_setup
}
@@ -76,6 +77,9 @@ src_prepare() {
test --verbose_failures --verbose_test_summary
test --spawn_strategy=standalone --genrule_strategy=standalone
EOF
+
+ eapply "${FILESDIR}/${P}-rename-gettid-functions.patch"
+ eapply "${FILESDIR}/${PN}-0.22.0-include-limits-for-gcc-11.patch"
}
src_compile() {