summaryrefslogtreecommitdiff
path: root/dev-util/babeltrace/babeltrace-1.5.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-22 05:40:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-22 05:40:04 +0000
commite621d36783ba0760925a62dd23c71495436fe753 (patch)
tree4e93396084f2d3592eb54edd2afd3458594f5f28 /dev-util/babeltrace/babeltrace-1.5.11.ebuild
parent51012ef0261a9da2e4487144906632d06607d3b9 (diff)
gentoo auto-resync : 22:02:2024 - 05:40:04
Diffstat (limited to 'dev-util/babeltrace/babeltrace-1.5.11.ebuild')
-rw-r--r--dev-util/babeltrace/babeltrace-1.5.11.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/babeltrace/babeltrace-1.5.11.ebuild b/dev-util/babeltrace/babeltrace-1.5.11.ebuild
new file mode 100644
index 000000000000..8fa57d29fca1
--- /dev/null
+++ b/dev-util/babeltrace/babeltrace-1.5.11.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A command-line tool and library to read and convert trace files"
+HOMEPAGE="https://babeltrace.org/"
+SRC_URI="https://www.efficios.com/files/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/popt
+ dev-libs/elfutils
+ sys-apps/util-linux
+"
+
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ app-alternatives/lex
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.5.8-slibtool.patch"
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable test glibtest) \
+ --enable-debug-info
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}