summaryrefslogtreecommitdiff
path: root/dev-util/argouml/argouml-0.34.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-util/argouml/argouml-0.34.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-util/argouml/argouml-0.34.ebuild')
-rw-r--r--dev-util/argouml/argouml-0.34.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-util/argouml/argouml-0.34.ebuild b/dev-util/argouml/argouml-0.34.ebuild
new file mode 100644
index 000000000000..fd031b69ec0f
--- /dev/null
+++ b/dev-util/argouml/argouml-0.34.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop xdg-utils java-pkg-2
+
+DESCRIPTION="Modelling tool that helps you do your design using UML"
+HOMEPAGE="http://argouml.tigris.org"
+BASE_URI="http://argouml-downloads.tigris.org/nonav/${P}"
+SRC_URI="${BASE_URI}/ArgoUML-${PV}.tar.gz
+ http://argouml-downloads.tigris.org/nonav/argouml-db-1.0/dbuml-module-1.0.4.zip
+ doc? (
+ ${BASE_URI}/manual-${PV}.pdf
+ ${BASE_URI}/quickguide-${PV}.pdf
+ )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc"
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}"
+
+src_compile() { :; }
+
+src_install() {
+ java-pkg_jarinto /opt/${PN}/lib
+ java-pkg_dojar ${P}/*.jar
+
+ java-pkg_jarinto /opt/${PN}/lib/ext
+ java-pkg_dojar ${P}/ext/*.jar release/ext/*.jar
+
+ java-pkg_dolauncher ${PN} --main org.argouml.application.Main
+
+ dodoc ${P}/README.txt
+
+ if use doc; then
+ find release/ \( -name Thumbs.db -o -name filelist.xml \) \
+ -delete || die
+ HTML_DOCS=( release/{Readme.htm,www} )
+ DOCS=(
+ "${DISTDIR}"/manual-${PV}.pdf
+ "${DISTDIR}"/quickguide-${PV}.pdf
+ )
+ einstalldocs
+ fi
+
+ newicon ${P}/icon/ArgoIcon128x128.png ${PN}.png || die
+ make_desktop_entry ${PN} "ArgoUML"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}