summaryrefslogtreecommitdiff
path: root/dev-util/act
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-21 23:40:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-21 23:40:13 +0000
commit51012ef0261a9da2e4487144906632d06607d3b9 (patch)
tree4bdd7443f88209d056985f2e4748277714e35829 /dev-util/act
parentf2d1966a40070fb5ba3279db49b8435c7c143802 (diff)
gentoo auto-resync : 21:02:2024 - 23:40:13
Diffstat (limited to 'dev-util/act')
-rw-r--r--dev-util/act/Manifest4
-rw-r--r--dev-util/act/act-0.2.59.ebuild22
-rw-r--r--dev-util/act/metadata.xml11
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/act/Manifest b/dev-util/act/Manifest
new file mode 100644
index 000000000000..879edaa29cee
--- /dev/null
+++ b/dev-util/act/Manifest
@@ -0,0 +1,4 @@
+DIST act-0.2.59-deps.tar.xz 141042948 BLAKE2B d433f89748585a642e06d31f1699bdd070c5d484f2115d3290238442adc96ea4abfa1b67c1b0dd05d790512545c25f8fa2ce0529f94d89f8475e7cc70d8025f2 SHA512 6550c886c117bdf148ebbe25f88bb2696fb52d5d9770439a6494e9cc1113a69e491206751e695edc85cf9c180c041eac61a7a1e48ddf316dfad2dccca15920e6
+DIST act-0.2.59.tar.gz 9271012 BLAKE2B 69d692cc2df6c00cbacf5015fb56eff19f741f9081d70d0e88b5f27a3743cddd9f4baecc2d1d88edd4416282c7195e691b49fd0bef269c8b100b695bdb61b375 SHA512 30b61ea07e31ca9ba7ee8a5111a743ab486c4e2b628796e92c879ed2c055594144506e370002f54f8c3544eb55023f11cb336c9323830edbdd5e5898b5a6b661
+EBUILD act-0.2.59.ebuild 476 BLAKE2B f719a375305a69609c1f405bd5714ae5973541307990eb5cbf4685615c4990998cef580e3c82fe3974ab37ee775cdf217173aacfeb851c1765ca005ef84da2af SHA512 5cb46ac4c763ad9a6db71fc46890f6aee1446ceb8f3aa056f89b515588a036cd08cf88815149267d4980c11a4061319fb0707da5558d1f665bbbdabb827038be
+MISC metadata.xml 324 BLAKE2B cbd4e3732c72060ed01aa84cf0ba575d2e271114433c8192705d1bfc4476b55bf178ce085bb3c8bace84325a3dd894ca9d2321e781a24180971e660de2a804bc SHA512 96a20ffc07ef5ef32b0f535848bf8963e3b77408dd00e4201cb9eb5a660e7eb431711950422e54419014ddb99a1891bab4c3a3dcb188634c56c8bbcde0e4c115
diff --git a/dev-util/act/act-0.2.59.ebuild b/dev-util/act/act-0.2.59.ebuild
new file mode 100644
index 000000000000..677e4e224350
--- /dev/null
+++ b/dev-util/act/act-0.2.59.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="run github workflows locally"
+HOMEPAGE="https://nektosact.com"
+SRC_URI="https://github.com/nektos/act/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ emake VERSION="${PV}" build
+}
+
+src_install() {
+dobin dist/local/act
+}
diff --git a/dev-util/act/metadata.xml b/dev-util/act/metadata.xml
new file mode 100644
index 000000000000..410072af64da
--- /dev/null
+++ b/dev-util/act/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">nektos/act</remote-id>
+ </upstream>
+</pkgmetadata>