summaryrefslogtreecommitdiff
path: root/dev-tex/style-check/style-check-0.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-tex/style-check/style-check-0.14.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-tex/style-check/style-check-0.14.ebuild')
-rw-r--r--dev-tex/style-check/style-check-0.14.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-tex/style-check/style-check-0.14.ebuild b/dev-tex/style-check/style-check-0.14.ebuild
new file mode 100644
index 000000000000..57b9aa826bd5
--- /dev/null
+++ b/dev-tex/style-check/style-check-0.14.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+DESCRIPTION="Parses LaTeX-formatted text in search of forbidden phrases"
+HOMEPAGE="http://www.cs.umd.edu/~nspring/software/style-check-readme.html https://github.com/nspring/style-check"
+SRC_URI="http://www.cs.umd.edu/~nspring/software/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="test"
+
+RDEPEND="dev-lang/ruby"
+DEPEND="test? ( dev-lang/ruby )"
+
+src_install() {
+ dodir /etc/style-check.d
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${ED}" install
+ dohtml README.html
+}