summaryrefslogtreecommitdiff
path: root/dev-tex/oesch/oesch-20080712.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-tex/oesch/oesch-20080712.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-tex/oesch/oesch-20080712.ebuild')
-rw-r--r--dev-tex/oesch/oesch-20080712.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-tex/oesch/oesch-20080712.ebuild b/dev-tex/oesch/oesch-20080712.ebuild
new file mode 100644
index 000000000000..278c8219c245
--- /dev/null
+++ b/dev-tex/oesch/oesch-20080712.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit latex-package
+
+DESCRIPTION="Metafont font used in Austrian schools for hand writing"
+HOMEPAGE="http://www.ctan.org/tex-archive/fonts/oesch/"
+# taken from http://www.ctan.org/tex-archive/fonts/oesch.zip
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~x86-fbsd"
+IUSE="examples"
+
+RDEPEND="!<dev-texlive/texlive-fontsextra-2007-r1"
+DEPEND="${RDEPEND}
+ dev-texlive/texlive-langgerman
+ app-arch/unzip"
+
+TEXMF="/usr/share/texmf-site"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ export VARTEXFONTS="${T}/fonts"
+ latex-package_src_install
+ insinto "${TEXMF}/fonts/source/public"
+ doins *.mf || die "failed to install metafont sources"
+ dodoc README LIESMICH
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins *.tex || die "failed to install examples"
+ fi
+}