summaryrefslogtreecommitdiff
path: root/dev-tex/latex-beamer/latex-beamer-3.41.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-tex/latex-beamer/latex-beamer-3.41.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-tex/latex-beamer/latex-beamer-3.41.ebuild')
-rw-r--r--dev-tex/latex-beamer/latex-beamer-3.41.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-tex/latex-beamer/latex-beamer-3.41.ebuild b/dev-tex/latex-beamer/latex-beamer-3.41.ebuild
new file mode 100644
index 000000000000..6ba01c8c75de
--- /dev/null
+++ b/dev-tex/latex-beamer/latex-beamer-3.41.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit latex-package
+
+DESCRIPTION="LaTeX class for creating presentations using a video projector"
+HOMEPAGE="https://github.com/josephwright/beamer"
+SRC_URI="https://github.com/josephwright/beamer/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 FDL-1.2 LPPL-1.3c"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples"
+
+DEPEND="dev-texlive/texlive-latex"
+RDEPEND=">=dev-tex/pgf-1.10
+ dev-tex/xcolor
+ !dev-tex/translator"
+
+S=${WORKDIR}/beamer-${PV}
+
+src_compile() {
+ if use doc; then
+ cd doc
+ emake -j1
+ fi
+}
+
+src_install() {
+ insinto /usr/share/texmf-site/tex/latex/beamer
+ doins -r base
+
+ dodoc AUTHORS README.md
+
+ if use doc ; then
+ docinto doc
+ dodoc -r doc/*
+ dosym "/usr/share/doc/${PF}/doc/" "${TEXMF}/doc/latex/beamer"
+ fi
+
+ use examples && dodoc -r examples solutions
+}