summaryrefslogtreecommitdiff
path: root/dev-tex/html2latex/html2latex-1.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-tex/html2latex/html2latex-1.1-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-tex/html2latex/html2latex-1.1-r1.ebuild')
-rw-r--r--dev-tex/html2latex/html2latex-1.1-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-tex/html2latex/html2latex-1.1-r1.ebuild b/dev-tex/html2latex/html2latex-1.1-r1.ebuild
new file mode 100644
index 000000000000..65cb145612cd
--- /dev/null
+++ b/dev-tex/html2latex/html2latex-1.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="Perl script to convert HTML files into formatted LaTeX"
+HOMEPAGE="http://html2latex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/html2latex/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+
+IUSE="imagemagick libwww"
+
+DEPEND="dev-perl/HTML-Tree
+ dev-perl/XML-Simple
+ imagemagick? ( media-gfx/imagemagick )
+ libwww? ( dev-perl/libwww-perl )"
+
+src_compile() {
+ # HTML::LaTex
+ cd HTML
+ perl-module_src_configure
+ perl-module_src_compile
+}
+
+src_install() {
+ dobin html2latex
+ doman html2latex.1
+ dodoc README TODO
+
+ # HTML::LaTex
+ cd HTML
+ perl-module_src_install
+ rm unwanted README.win
+ rm $(find "${D}" -name README.win.txt) || die
+}