summaryrefslogtreecommitdiff
path: root/dev-tex/dvi2tty/dvi2tty-5.3.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-tex/dvi2tty/dvi2tty-5.3.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-tex/dvi2tty/dvi2tty-5.3.4.ebuild')
-rw-r--r--dev-tex/dvi2tty/dvi2tty-5.3.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-tex/dvi2tty/dvi2tty-5.3.4.ebuild b/dev-tex/dvi2tty/dvi2tty-5.3.4.ebuild
new file mode 100644
index 000000000000..a33fc5e26bd5
--- /dev/null
+++ b/dev-tex/dvi2tty/dvi2tty-5.3.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Preview dvi-files on text-only devices"
+HOMEPAGE="http://www.ctan.org/tex-archive/dviware/"
+SRC_URI="ftp://ftp.mesa.nl/pub/dvi2tty/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cflags.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake
+}
+
+src_install() {
+ dobin dvi2tty disdvi
+ doman dvi2tty.1 disdvi.1
+ dodoc README TODO
+}