summaryrefslogtreecommitdiff
path: root/dev-tex/cpp2latex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-tex/cpp2latex
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-tex/cpp2latex')
-rw-r--r--dev-tex/cpp2latex/Manifest6
-rw-r--r--dev-tex/cpp2latex/cpp2latex-2.3-r2.ebuild19
-rw-r--r--dev-tex/cpp2latex/files/cpp2latex-2.3-gcc43.patch12
-rw-r--r--dev-tex/cpp2latex/files/cpp2latex-2.3-tests.patch15
-rw-r--r--dev-tex/cpp2latex/files/cpp2latex-2.3.patch44
-rw-r--r--dev-tex/cpp2latex/metadata.xml8
6 files changed, 104 insertions, 0 deletions
diff --git a/dev-tex/cpp2latex/Manifest b/dev-tex/cpp2latex/Manifest
new file mode 100644
index 000000000000..678bf0310636
--- /dev/null
+++ b/dev-tex/cpp2latex/Manifest
@@ -0,0 +1,6 @@
+AUX cpp2latex-2.3-gcc43.patch 345 BLAKE2B 6bc47b4b7086a17ee874e91db150eb22d892983cc325450bfd03a56236c44ad7c10b4157d61a5159d5b328c282b87eca77f4ff5185f42e2ec1cd79ace5f12e5e SHA512 b1a74fb536687e1c3974fd4747c3b0ad83ec331b8ef89aabfd375202ff6d9df1ea230bc807b76513ddb08af538122e6296c15a477f9d472903f9ea85ae3869de
+AUX cpp2latex-2.3-tests.patch 443 BLAKE2B e4dc503430f18664079612ba7a62ec049bbda5783cfd2b28592967a570451b987f448aece713b49a5667fee2cb4af274dfa9093e4c196352f51ec7fcc5acbdfe SHA512 21da2eeb1616993c82dddef8f4214c1e68b40cea40d8497a8a24e1151ef5680c72de3a2660a34bcc1e02d832558643e1a46a20675ed2a50f71500f7d346cec1c
+AUX cpp2latex-2.3.patch 1261 BLAKE2B 958c861f1b722161f61407885c19408c38f0b48f9316c1c2dd76edd7d1e1dfb43cbde13ca4d92e9295c2dd448a56e18552aa2b825beab33686a7a567fb5dcf00 SHA512 8effdd739ebee882c4449ab40020086a977087be449948729c194d8a14e6d2b053c061a2ca3291229c34a8cfebf930118392a288224fad8fcd36dda2d0402c08
+DIST cpp2latex-2.3.tar.gz 483213 BLAKE2B eed33201db3a2144d59d200386e44976f6c7e7b621516c23ac35c195f7fa64d65cd156ef6a4d610dffaab62ca62cc73ab1894cc8bf94284e61375be44ad6ad06 SHA512 af4a13a79b2eb14556f35ca372a0c4f5fec5ddc52a712e998fb73dfe0451c1d95eb857f905a9fd66fac72f734fdcad50b9bca2769780950c7b04fa56912812e1
+EBUILD cpp2latex-2.3-r2.ebuild 498 BLAKE2B 33ccb32d168f727a910df7409d42ead5e275c37c21edc83d3e0ec074fcc0b6e7e7037c8ea69f6ab4c99d61482fcf8c7a9735afd3d807dca8e398b3211294c2f6 SHA512 fc7e14f89b016e5ea14e0523fbbdb7f436d205083155ac06d3d56c680159c4232b3412d58d109423fa0f59bfde8f931e7fc8704e7fc3fdca1478e2a4ed1103a4
+MISC metadata.xml 245 BLAKE2B ee3a163cfe0a4bc59c0dfb46f9ddb580e2d259b4d0e33cb4e684eb9e6d4b901bf97c6edd891f3b75a613a782f1b89318d0ee3ec9bee4e34c4441d9e8f4267678 SHA512 1653777623e2c15e1ce13229e396723b2cc9c214983e0f8592de98c01a31badc6c38c6735ed44f937d145883b43fb6f049af3eddb9ff96b18c96ccf8f67dd690
diff --git a/dev-tex/cpp2latex/cpp2latex-2.3-r2.ebuild b/dev-tex/cpp2latex/cpp2latex-2.3-r2.ebuild
new file mode 100644
index 000000000000..fdf89e105561
--- /dev/null
+++ b/dev-tex/cpp2latex/cpp2latex-2.3-r2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A program to convert C++ code to LaTeX source"
+HOMEPAGE="http://www.arnoldarts.de/cpp2latex/"
+SRC_URI="http://www.arnoldarts.de/files/cpp2latex/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+
+# first patch: bug #44585, second patch bug #227863
+PATCHES=(
+ "${FILESDIR}/${P}.patch"
+ "${FILESDIR}/${P}-gcc43.patch"
+ "${FILESDIR}/${P}-tests.patch"
+)
diff --git a/dev-tex/cpp2latex/files/cpp2latex-2.3-gcc43.patch b/dev-tex/cpp2latex/files/cpp2latex-2.3-gcc43.patch
new file mode 100644
index 000000000000..006560506676
--- /dev/null
+++ b/dev-tex/cpp2latex/files/cpp2latex-2.3-gcc43.patch
@@ -0,0 +1,12 @@
+Index: cpp2latex-2.3/cpp2latex/main.cpp
+===================================================================
+--- cpp2latex-2.3.orig/cpp2latex/main.cpp
++++ cpp2latex-2.3/cpp2latex/main.cpp
+@@ -22,6 +22,7 @@
+ #include <iostream>
+ #include <stdlib.h>
+ #include <string>
++#include <cstring>
+ #include <fstream>
+ #include <vector>
+ #include <stdio.h>
diff --git a/dev-tex/cpp2latex/files/cpp2latex-2.3-tests.patch b/dev-tex/cpp2latex/files/cpp2latex-2.3-tests.patch
new file mode 100644
index 000000000000..621c43d28156
--- /dev/null
+++ b/dev-tex/cpp2latex/files/cpp2latex-2.3-tests.patch
@@ -0,0 +1,15 @@
+Index: cpp2latex-2.3/cpp2latex/getopttest.cpp
+===================================================================
+--- cpp2latex-2.3.orig/cpp2latex/getopttest.cpp
++++ cpp2latex-2.3/cpp2latex/getopttest.cpp
+@@ -2,7 +2,9 @@
+ #include <iostream>
+ #include <getopt.h>
+
+-void main( int argc, char* argv[] )
++using namespace std;
++
++int main( int argc, char* argv[] )
+ {
+ int optch=0, optc=1;
+ while( ( optch = getopt( argc,argv, "h:a:k" ) ) > 0 )
diff --git a/dev-tex/cpp2latex/files/cpp2latex-2.3.patch b/dev-tex/cpp2latex/files/cpp2latex-2.3.patch
new file mode 100644
index 000000000000..b72b870ba53b
--- /dev/null
+++ b/dev-tex/cpp2latex/files/cpp2latex-2.3.patch
@@ -0,0 +1,44 @@
+--- a/cpp2latex/main.cpp Thu Mar 6 08:15:36 2003
++++ a/cpp2latex/main.cpp Tue Jan 24 21:47:17 2006
+@@ -27,12 +27,14 @@
+ #include <stdio.h>
+ #include <getopt.h>
+
++using namespace std;
++
+ struct replace{
+ std::string voraus;
+ std::string ersetzt;
+ };
+
+-std::vector <replace> rules;
++std::vector<struct replace> rules;
+ std::string syntax( std::ifstream *src, char *c );
+ void initReplace();
+ bool satzzeichen( char c );
+@@ -162,9 +164,13 @@
+ if( comment && !comment1 )
+ {
+ file.get(c);
+- if(c=='/') { out+="/}"; comment=false; }
+- else { if(c=='\n') out+="\\\\"; }
+- if( !( (c=='*')||(c=='/') )) out+=c;
++ if(c=='/') {
++ out+="/}";
++ comment=false;
++ } else if (c=='\n') out+="\\\\";
++ /* .alex. 1 line substitution*/
++ else file.seekg(-1,ios::cur);
++ //if( !( (c=='*')||(c=='/') )) out+=c;
+ }
+ break;
+
+@@ -323,7 +329,7 @@
+ /** initialize the replacementrules */
+ void initReplace()
+ {
+-replace dummy;
++ struct replace dummy;
+ dummy.voraus = "and"; dummy.ersetzt = "\\textbf{and}"; rules.push_back(dummy);
+ dummy.voraus = "and_eq"; dummy.ersetzt = "\\textbf{and\\underline\\ eq}"; rules.push_back(dummy);
+ dummy.voraus = "asm"; dummy.ersetzt = "\\textbf{asm}"; rules.push_back(dummy);
diff --git a/dev-tex/cpp2latex/metadata.xml b/dev-tex/cpp2latex/metadata.xml
new file mode 100644
index 000000000000..13170c3184d8
--- /dev/null
+++ b/dev-tex/cpp2latex/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>tex@gentoo.org</email>
+ <name>Gentoo TeX Project</name>
+</maintainer>
+</pkgmetadata>