summaryrefslogtreecommitdiff
path: root/dev-tex/cpp2latex/cpp2latex-2.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-tex/cpp2latex/cpp2latex-2.3-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-tex/cpp2latex/cpp2latex-2.3-r1.ebuild')
-rw-r--r--dev-tex/cpp2latex/cpp2latex-2.3-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-tex/cpp2latex/cpp2latex-2.3-r1.ebuild b/dev-tex/cpp2latex/cpp2latex-2.3-r1.ebuild
new file mode 100644
index 000000000000..719cee656d0f
--- /dev/null
+++ b/dev-tex/cpp2latex/cpp2latex-2.3-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils
+
+DESCRIPTION="A program to convert C++ code to LaTeX source"
+HOMEPAGE="http://www.arnoldarts.de/drupal/?q=Cpp2LaTeX"
+SRC_URI="http://www.arnoldarts.de/drupal/files/downloads/cpp2latex/${P}.tar.gz"
+LICENSE="GPL-2"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+
+# although it makes sense to have tex installed, it is
+# neither a compile or runtime dependency
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}/cpp2latex"
+ # bug 44585
+ epatch "${FILESDIR}/cpp2latex-2.3.patch"
+ # bug #227863
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+ epatch "${FILESDIR}/${P}-tests.patch"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+}