summaryrefslogtreecommitdiff
path: root/dev-tcltk/tls/tls-1.7.22.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-15 12:21:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-15 12:21:13 +0000
commitcf5d856691cbc347f5816a181e5bf767792afa55 (patch)
tree239945541c80dfa78133d5e9ab5c52c25a222b09 /dev-tcltk/tls/tls-1.7.22.ebuild
parentbb007f0b04c719fd2b846d177c3c4739fdb7c318 (diff)
gentoo auto-resync : 15:03:2023 - 12:21:13
Diffstat (limited to 'dev-tcltk/tls/tls-1.7.22.ebuild')
-rw-r--r--dev-tcltk/tls/tls-1.7.22.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-tcltk/tls/tls-1.7.22.ebuild b/dev-tcltk/tls/tls-1.7.22.ebuild
deleted file mode 100644
index 53f983e10292..000000000000
--- a/dev-tcltk/tls/tls-1.7.22.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-MY_P="tcl${P}"
-
-DESCRIPTION="TLS OpenSSL extension to Tcl"
-HOMEPAGE="http://tls.sourceforge.net/"
-SRC_URI="https://core.tcl.tk/tcltls/uv/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="tk"
-
-DEPEND="
- dev-lang/tcl:0=
- dev-libs/openssl:0=
- tk? ( dev-lang/tk:0= )"
-RDEPEND="${DEPEND}"
-
-RESTRICT="test"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=( "${FILESDIR}"/${P}-ldflags.patch )
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- --with-ssl-dir="${EPREFIX}/usr" \
- --with-tcl="${EPREFIX}/usr/$(get_libdir)"
-}
-
-src_install() {
- default
- dodoc tls.htm
-
- if [[ ${CHOST} == *-darwin* ]] ; then
- # this is ugly, but fixing the makefile mess is even worse
- local loc=usr/$(get_libdir)/tls1.7/libtls1.7.dylib
- install_name_tool -id "${EPREFIX}"/${loc} "${ED}"/${loc} || die
- fi
-}