summaryrefslogtreecommitdiff
path: root/dev-tcltk/thread/thread-2.8.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-11 12:45:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-11 12:45:52 +0000
commit8b4349b75818953123e2d4b80963181a9640c8e3 (patch)
treebd5d9faded1a62202daa603120c8ccd5216c79e9 /dev-tcltk/thread/thread-2.8.9.ebuild
parente96f09a840f1ac865c504febe44bad831c63750e (diff)
gentoo auto-resync : 11:03:2024 - 12:45:51
Diffstat (limited to 'dev-tcltk/thread/thread-2.8.9.ebuild')
-rw-r--r--dev-tcltk/thread/thread-2.8.9.ebuild21
1 files changed, 20 insertions, 1 deletions
diff --git a/dev-tcltk/thread/thread-2.8.9.ebuild b/dev-tcltk/thread/thread-2.8.9.ebuild
index d17e1037fa84..ab64d0048cc7 100644
--- a/dev-tcltk/thread/thread-2.8.9.ebuild
+++ b/dev-tcltk/thread/thread-2.8.9.ebuild
@@ -3,11 +3,18 @@
EAPI=8
+inherit autotools
+
MY_P="${PN}-$(ver_rs 0- '-')"
+TCLCONFIGId=4a924db4fb37fa0c7cc2ae987b294dbaa97bc713
DESCRIPTION="Tcl Thread extension"
HOMEPAGE="http://www.tcl.tk/"
-SRC_URI="https://github.com/tcltk/${PN}/archive/refs/tags/${MY_P}.tar.gz"
+SRC_URI="
+ https://github.com/tcltk/${PN}/archive/refs/tags/${MY_P}.tar.gz
+ https://github.com/tcltk/tclconfig/archive/${TCLCONFIGId}.tar.gz
+ -> tclconfig-2023.12.11.tar.gz
+"
LICENSE="BSD"
SLOT="0"
@@ -24,6 +31,18 @@ S="${WORKDIR}"/${PN}-${MY_P}
PATCHES=( "${FILESDIR}"/${PN}-2.8.5-musl.patch )
+src_prepare() {
+ ln -s ../tclconfig-${TCLCONFIGId} tclconfig || die
+ echo "unknown" > manifest.uuid || die
+ default
+
+ # Search for libs in libdir not just exec_prefix/lib
+ sed -i -e 's:${exec_prefix}/lib:${libdir}:' \
+ aclocal.m4 || die "sed failed"
+
+ eautoreconf
+}
+
src_configure() {
econf --with-tclinclude="${EPREFIX}/usr/include" \
--with-tcl="${EPREFIX}/usr/$(get_libdir)"