summaryrefslogtreecommitdiff
path: root/dev-tcltk/tclx/files/tclx-8.4.4-musl.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-16 00:22:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-16 00:22:55 +0000
commitb4c2aa4f33970ea2c862e0f7e57f01564bc63002 (patch)
tree1e180579eefb953f3ef09005ad064af004885e1c /dev-tcltk/tclx/files/tclx-8.4.4-musl.patch
parent0ffb93f7e1f8ab9362275c3ba3e7a7dff0939a26 (diff)
gentoo auto-resync : 16:03:2023 - 00:22:55
Diffstat (limited to 'dev-tcltk/tclx/files/tclx-8.4.4-musl.patch')
-rw-r--r--dev-tcltk/tclx/files/tclx-8.4.4-musl.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-tcltk/tclx/files/tclx-8.4.4-musl.patch b/dev-tcltk/tclx/files/tclx-8.4.4-musl.patch
new file mode 100644
index 000000000000..2fc45e05b6ab
--- /dev/null
+++ b/dev-tcltk/tclx/files/tclx-8.4.4-musl.patch
@@ -0,0 +1,25 @@
+--- a/configure.in 2023-03-15 22:00:11.725506240 +0100
++++ b/configure.in 2023-03-15 22:00:29.230246904 +0100
+@@ -253,6 +253,7 @@
+
+ AC_CHECK_FUNC(inet_aton, , [AC_DEFINE(NO_INET_ATON)])
+ AC_CHECK_FUNC(gethostname, , [AC_DEFINE(NO_GETHOSTNAME)])
++ AC_CHECK_FUNCS([rresvport])
+
+ #-------------------------------------------------------------------------
+ # Check for additional libraries the Tcl/Tk does not check for.
+--- a/unix/tclXunixSock.c 2023-03-15 22:02:32.255424538 +0100
++++ b/unix/tclXunixSock.c 2023-03-15 22:03:35.094493443 +0100
+@@ -194,10 +194,12 @@
+ * Allocate a reserved port if requested.
+ */
+ if (getReserved) {
++#ifdef HAVE_RRESVPORT
+ int port;
+ if (rresvport (&port) < 0)
+ goto unixError;
+ local.sin_port = port;
++#endif
+ }
+
+ /*