summaryrefslogtreecommitdiff
path: root/dev-tcltk/tclpython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-tcltk/tclpython
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-tcltk/tclpython')
-rw-r--r--dev-tcltk/tclpython/Manifest5
-rw-r--r--dev-tcltk/tclpython/files/tclpython-4.1-python-3.patch229
-rw-r--r--dev-tcltk/tclpython/metadata.xml8
-rw-r--r--dev-tcltk/tclpython/tclpython-4.1-r4.ebuild54
-rw-r--r--dev-tcltk/tclpython/tclpython-4.1-r6.ebuild55
5 files changed, 0 insertions, 351 deletions
diff --git a/dev-tcltk/tclpython/Manifest b/dev-tcltk/tclpython/Manifest
deleted file mode 100644
index 42240d29b5ea..000000000000
--- a/dev-tcltk/tclpython/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-AUX tclpython-4.1-python-3.patch 8863 BLAKE2B 6c1c2fa8f29240b6703911fde24519961f740cdac0d331cea7df3fb90fed769319ca0c00422ebe58275be90584c28debdf906f1b8c923e96d0c834a2af621077 SHA512 530d057501ef72e7f28cfff1f0af2076b93739085154fc4d20a5b59b26e33d1418bf694093b05e840055734438232dd9414ba0262720fb4bd2e35249769b24e7
-DIST tclpython-4.1.tar.bz2 10580 BLAKE2B 98d4783cc52bc907c21d50ee393e25ee084b449db7c393c16b0b1f0420469bd0904d16dc2a6806b776dad7dabd521e5f2e8cc942c720d9e69750385302355608 SHA512 5f08e7129a7d9afeb1ac6bf1ab1c83ad3bb481593c9516c0653c7b4ba0dfb1b3129a336e64b998cec8ef2d2377a6a366b73c640d25839ab280d5079c0b220d54
-EBUILD tclpython-4.1-r4.ebuild 1264 BLAKE2B b747d07338d133dd6962695bd92c4499dfca8182d1b2d9befd6aeba8125880fbe7807e6bcf33d113af32a08d2c980a41f557a5039ba659e3624bd9bb50aafe0f SHA512 7041ef994f59b536fca064a5aaf455ba1a7e67b0a96e9e619b7d47f493f875eed5275816b94f56fe3a82f53dbaaf530cca12b16e9eeca6aae704b2b4e1377900
-EBUILD tclpython-4.1-r6.ebuild 1296 BLAKE2B eefd716b5ee7896ab7044d57836cd0cb20e5a9b3a6b8b6b8fa0613b93d23bc21c51b1e8783feba480fd4d430c32e2759fc9e85d75727243e58b49ad4ce496c3b SHA512 ea7b582fbc1796eaaf6195868f1c31c2fdef6d7fe1c7df87437fafc0a48e86110dda9a80dd34b40347356d0cfe4ec58d2021bdd396f23ddeac8914f1bf216c5c
-MISC metadata.xml 259 BLAKE2B 174c3c7b4292350e73a38b09d473abba172ee6e82ca1b5bcb6815a9927609a7fbac063a19498e7c5deaa32530d10d8c493760ff5b6e489f821410cfeccadf566 SHA512 5943f2c9dc9a55862bae4c01be9e1f27304ffc1ce48d67341b4a19793c0bb11fe3d1a419af924ac360aeeafbce28018971602019a559a8a6c5939e05e3567639
diff --git a/dev-tcltk/tclpython/files/tclpython-4.1-python-3.patch b/dev-tcltk/tclpython/files/tclpython-4.1-python-3.patch
deleted file mode 100644
index 2a26f647c10e..000000000000
--- a/dev-tcltk/tclpython/files/tclpython-4.1-python-3.patch
+++ /dev/null
@@ -1,229 +0,0 @@
---- a/tclpython.c 2006-03-07 16:28:03.000000000 +0300
-+++ b/tclpython.c 2014-05-06 23:33:41.713623943 +0400
-@@ -19,13 +19,83 @@
- $ cc -fpic -I/usr/local/include/tcltk/tcl8.3 -c tclthread.c
- $ ld -o tclpython.so -Bshareable -L/usr/X11R6/lib -L/usr/local/lib -L/usr/local/share/python/config tclpython.o tclthread.o -lpython -lutil -lreadline -ltermcap -lcrypt -lgmp -lgdbm -lpq -lz -ltcl83 -ltk83 -lX11
-
-+Patched for Python 3 with respect to https://github.com/facebook/fbthrift/blob/master/thrift/lib/py/protocol/fastbinary.c
-+
- */
-
- #include <Python.h>
- #include <tcl.h>
--#include <cStringIO.h>
-+
-+#if PY_MAJOR_VERSION >= 3
-+ #define PyInt_FromLong PyLong_FromLong
-+ #define PyInt_AsLong PyLong_AsLong
-+ #define PyString_FromStringAndSize PyBytes_FromStringAndSize
-+#else
-+ #include <cStringIO.h>
-+#endif
-+
- #include "tclpython.h"
-
-+// Mostly copied from cStringIO.c
-+#if PY_MAJOR_VERSION >= 3
-+
-+/** io module in python3. */
-+static PyObject* Python3IO;
-+
-+typedef struct {
-+ PyObject_HEAD
-+ char *buf;
-+ Py_ssize_t pos, string_size;
-+} IOobject;
-+
-+#define IOOOBJECT(O) ((IOobject*)(O))
-+
-+static int
-+IO__opencheck(IOobject *self) {
-+ if (!self->buf) {
-+ PyErr_SetString(PyExc_ValueError,
-+ "I/O operation on closed file");
-+ return 0;
-+ }
-+ return 1;
-+}
-+
-+static PyObject *
-+IO_cgetval(PyObject *self) {
-+ if (!IO__opencheck(IOOOBJECT(self))) return NULL;
-+ assert(IOOOBJECT(self)->pos >= 0);
-+ return PyBytes_FromStringAndSize(((IOobject*)self)->buf,
-+ ((IOobject*)self)->pos);
-+}
-+#endif
-+
-+/* -- PYTHON MODULE SETUP STUFF --- */
-+
-+static PyObject *pythonTclEvaluate(PyObject *self, PyObject *args);
-+
-+static PyMethodDef tclMethods[] = {
-+ {"eval", pythonTclEvaluate, METH_VARARGS, "Evaluate a Tcl script."},
-+ {0, 0, 0, 0} /* sentinel */
-+};
-+
-+#if PY_MAJOR_VERSION >= 3
-+struct module_state {
-+ PyObject *error;
-+};
-+
-+static struct PyModuleDef TclModuleDef = {
-+ PyModuleDef_HEAD_INIT,
-+ "tcl",
-+ NULL,
-+ sizeof(struct module_state),
-+ tclMethods,
-+ NULL,
-+ NULL,
-+ NULL,
-+ NULL
-+};
-+#endif
-+
- #ifndef WIN32
- /* George Petasis, 21 Feb 2006:
- * The following check cannot be handled correctly
-@@ -66,13 +136,13 @@
-
- static int pythonInterpreter(ClientData clientData, Tcl_Interp *interpreter, int numberOfArguments, Tcl_Obj * CONST arguments[])
- {
-- int identifier;
-+ intptr_t identifier;
- PyObject *output;
- PyObject *message;
- PyObject *result;
- PyObject *globals;
- char *string = 0;
-- int length;
-+ Py_ssize_t length;
- Tcl_Obj *object;
- struct Tcl_HashEntry *entry;
- unsigned evaluate;
-@@ -111,12 +181,22 @@
- /* choose start token depending on whether this is an evaluation or an execution: */
- result = PyRun_String(Tcl_GetString(arguments[2]), (evaluate? Py_eval_input: Py_file_input), globals, globals);
- if (result == 0) { /* an error occured */
-+#if PY_MAJOR_VERSION >= 3
-+ output = PyObject_CallMethod(Python3IO, "BytesIO", "()");
-+#else
- output = PycStringIO->NewOutput(1024); /* use a reasonable initial size but big enough to handle most cases */
-- PySys_SetObject("stderr", output); /* capture all interpreter error output */
-+#endif
-+ PySys_SetObject("sys.stderr", output); /* capture all interpreter error output */
- PyErr_Print(); /* so that error is printed on standard error, redirected above */
-+#if PY_MAJOR_VERSION >= 3
-+ message = IO_cgetval(output);
-+ string = PyBytes_AsString(message);
-+ length = (string == NULL) ? 0 : strlen(string);
-+#else
- message = PycStringIO->cgetvalue(output);
- string = PyString_AsString(message);
- length = PyString_Size(message);
-+#endif
- if ((length > 0) && (string[length - 1] == '\n')) length--; /* eventually remove trailing new line character */
- object = Tcl_NewObj();
- Tcl_AppendStringsToObj(object, Tcl_GetString(arguments[0]), ": ", 0); /* identify interpreter in error */
-@@ -124,7 +204,11 @@
- Py_DECREF(output);
- } else {
- if (evaluate) {
-+#if PY_MAJOR_VERSION >= 3
-+ string = PyUnicode_AsUTF8(PyObject_Str(result));
-+#else
- string = PyString_AsString(PyObject_Str(result));
-+#endif
- object = Tcl_NewStringObj(string, -1); /* return evaluation result */
- } else /* execute */
- object = Tcl_NewObj(); /* always return an empty result or an error */
-@@ -139,9 +223,9 @@
-
- Tcl_Interp *tclInterpreter(CONST char *name) /* public function for use in extensions to this extension */
- {
-- int identifier;
-+ intptr_t identifier;
-
-- if ((sscanf(name, "tcl%u", &identifier) == 0) || (identifier != 0)) {
-+ if ((sscanf(name, "tcl%lu", &identifier) == 0) || (identifier != 0)) {
- return 0; /* invalid name */
- } else {
- return mainInterpreter; /* sole available interpreter */
-@@ -188,14 +272,9 @@
- return Py_BuildValue("s", result);
- }
-
--static PyMethodDef tclMethods[] = {
-- {"eval", pythonTclEvaluate, METH_VARARGS, "Evaluate a Tcl script."},
-- {0, 0, 0, 0} /* sentinel */
--};
--
- static int newInterpreter(Tcl_Interp *interpreter)
- {
-- int identifier;
-+ intptr_t identifier;
- Tcl_Obj *object;
- int created;
- #ifdef WITH_THREAD
-@@ -214,19 +293,31 @@
- return TCL_ERROR;
- } else {
- Py_Initialize(); /* initialize main interpreter */
-+#if PY_MAJOR_VERSION >= 3
-+ Python3IO = PyImport_ImportModule("io");
-+#else
- PycString_IMPORT;
-+#endif
- }
- Tcl_SetHashValue(Tcl_CreateHashEntry(&threadStates, (ClientData)identifier, &created), 0);
- #else
- if (existingInterpreters == 0) {
- Py_Initialize(); /* initialize main interpreter */
- PyEval_InitThreads(); /* initialize and acquire the global interpreter lock */
-+#if PY_MAJOR_VERSION >= 3
-+ Python3IO = PyImport_ImportModule("io");
-+#else
- PycString_IMPORT;
-+#endif
- globalState = PyThreadState_Swap(0); /* save the global thread */
- } else {
- PyEval_AcquireLock(); /* needed in order to be able to create a new interpreter */
- }
-+#if PY_MAJOR_VERSION >= 3
-+ if (Python3IO == 0) { /* make sure string input/output is properly initialized */
-+#else
- if (PycStringIO == 0) { /* make sure string input/output is properly initialized */
-+#endif
- Tcl_SetResult(interpreter, "fatal error: could not initialize Python string input/output module", TCL_STATIC);
- return TCL_ERROR;
- }
-@@ -250,7 +341,11 @@
- newIdentifier++;
- #endif
- existingInterpreters++;
-+#if PY_MAJOR_VERSION >= 3
-+ tcl = PyModule_Create(&TclModuleDef);
-+#else
- tcl = Py_InitModule("tcl", tclMethods); /* add a new 'tcl' module to the python interpreter */
-+#endif
- Py_INCREF(tcl);
- PyModule_AddObject(PyImport_AddModule("__builtin__"), "tcl", tcl);
- return TCL_OK;
-@@ -260,7 +355,7 @@
- {
- int index;
- char *name;
-- int identifier;
-+ intptr_t identifier;
- struct Tcl_HashEntry *entry;
- Tcl_Obj *object;
- #ifdef WITH_THREAD
-@@ -270,7 +365,7 @@
- for (index = 0; index < numberOfArguments; index++) {
- name = Tcl_GetString(arguments[index]); /* interpreter name is "pythonN" */
- entry = 0;
-- if (sscanf(name, "python%u", &identifier) == 1) {
-+ if (sscanf(name, "python%lu", &identifier) == 1) {
- identifier = atoi(name + 6);
- entry = Tcl_FindHashEntry(&threadStates, (ClientData)identifier);
- }
diff --git a/dev-tcltk/tclpython/metadata.xml b/dev-tcltk/tclpython/metadata.xml
deleted file mode 100644
index 227dda5ba584..000000000000
--- a/dev-tcltk/tclpython/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>tcltk@gentoo.org</email>
- <name>Gentoo Tcltk Project</name>
- </maintainer>
-</pkgmetadata>
diff --git a/dev-tcltk/tclpython/tclpython-4.1-r4.ebuild b/dev-tcltk/tclpython/tclpython-4.1-r4.ebuild
deleted file mode 100644
index d76649cf5f20..000000000000
--- a/dev-tcltk/tclpython/tclpython-4.1-r4.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit eutils multilib python-single-r1 toolchain-funcs
-
-DESCRIPTION="Python package for Tcl"
-HOMEPAGE="http://jfontain.free.fr/tclpython.htm"
-SRC_URI="http://jfontain.free.fr/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
- dev-lang/tcl:0="
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-python-3.patch
-)
-
-src_prepare() {
- epatch "${PATCHES[@]}"
-}
-
-src_compile() {
- local cfile="tclpython tclthread"
- for src in ${cfile}; do
- compile="$(tc-getCC) -shared -fPIC ${CFLAGS} -I$(python_get_includedir) -c ${src}.c"
- einfo "${compile}"
- eval "${compile}" || die
- done
-
- link="$(tc-getCC) -fPIC -shared ${LDFLAGS} -o tclpython.so.${PV} tclpython.o tclthread.o -lpthread -lutil $(python_get_LIBS) -ltcl"
- einfo "${link}"
- eval "${link}" || die
-}
-
-src_install() {
- insinto /usr/$(get_libdir)/tclpython
- doins tclpython.so.${PV} pkgIndex.tcl
- fperms 775 /usr/$(get_libdir)/tclpython/tclpython.so.${PV}
- dosym tclpython.so.${PV} /usr/$(get_libdir)/tclpython/tclpython.so
-
- dodoc CHANGES INSTALL README
- dohtml tclpython.htm
-}
diff --git a/dev-tcltk/tclpython/tclpython-4.1-r6.ebuild b/dev-tcltk/tclpython/tclpython-4.1-r6.ebuild
deleted file mode 100644
index 6359b225c9ff..000000000000
--- a/dev-tcltk/tclpython/tclpython-4.1-r6.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit eutils multilib python-single-r1 toolchain-funcs
-
-DESCRIPTION="Python package for Tcl"
-HOMEPAGE="http://jfontain.free.fr/tclpython.htm"
-SRC_URI="http://jfontain.free.fr/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
- dev-lang/tcl:0=
- sys-libs/binutils-libs"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-python-3.patch
-)
-
-src_prepare() {
- epatch "${PATCHES[@]}"
-}
-
-src_compile() {
- local cfile="tclpython tclthread"
- for src in ${cfile}; do
- compile="$(tc-getCC) -shared -fPIC ${CFLAGS} -I$(python_get_includedir) -c ${src}.c"
- einfo "${compile}"
- eval "${compile}" || die
- done
-
- link="$(tc-getCC) -fPIC -shared ${LDFLAGS} -o tclpython.so.${PV} tclpython.o tclthread.o -lpthread -lutil $(python_get_LIBS) -ltcl"
- einfo "${link}"
- eval "${link}" || die
-}
-
-src_install() {
- insinto /usr/$(get_libdir)/tclpython
- doins tclpython.so.${PV} pkgIndex.tcl
- fperms 775 /usr/$(get_libdir)/tclpython/tclpython.so.${PV}
- dosym tclpython.so.${PV} /usr/$(get_libdir)/tclpython/tclpython.so
-
- dodoc CHANGES INSTALL README
- dohtml tclpython.htm
-}