summaryrefslogtreecommitdiff
path: root/dev-tcltk/tcllib/tcllib-1.21.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-07 22:36:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-07 22:36:52 +0100
commitd6afc0279cc61e309c2696d5bd758451f97b6a5b (patch)
tree866a5fcc6d730d20b6c74fd50e89033658b8bac2 /dev-tcltk/tcllib/tcllib-1.21.ebuild
parent4f49fc7caa0253a7ab164331f55bd4c70bba1bf7 (diff)
gentoo auto-resync : 07:09:2022 - 22:36:52
Diffstat (limited to 'dev-tcltk/tcllib/tcllib-1.21.ebuild')
-rw-r--r--dev-tcltk/tcllib/tcllib-1.21.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-tcltk/tcllib/tcllib-1.21.ebuild b/dev-tcltk/tcllib/tcllib-1.21.ebuild
new file mode 100644
index 000000000000..1e975342d4b7
--- /dev/null
+++ b/dev-tcltk/tcllib/tcllib-1.21.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit virtualx
+
+DESCRIPTION="Tcl Standard Library"
+HOMEPAGE="http://www.tcl.tk/software/tcllib/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="examples"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-lang/tcl:0=
+ dev-tcltk/tdom
+ "
+DEPEND="${RDEPEND}"
+
+DOCS=(
+ ChangeLog DESCRIPTION.txt README.md devdoc/README.developer
+ devdoc/critcl-tcllib.txt devdoc/dirlayout_install.txt
+ devdoc/indexing.txt
+)
+HTML_DOCS=( idoc/www )
+
+PATCHES=( "${FILESDIR}"/${P}-test.patch )
+
+src_prepare() {
+ default
+ rm modules/httpd/httpd.test || die
+}
+
+src_test() {
+ USER= virtx emake test_batch
+}
+
+src_install() {
+ default
+
+ if use examples ; then
+ for f in $(find examples -type f); do
+ docinto $(dirname $f)
+ dodoc $f
+ done
+ fi
+}