summaryrefslogtreecommitdiff
path: root/dev-tcltk/tcl3d/tcl3d-0.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /dev-tcltk/tcl3d/tcl3d-0.5.0.ebuild
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'dev-tcltk/tcl3d/tcl3d-0.5.0.ebuild')
-rw-r--r--dev-tcltk/tcl3d/tcl3d-0.5.0.ebuild39
1 files changed, 21 insertions, 18 deletions
diff --git a/dev-tcltk/tcl3d/tcl3d-0.5.0.ebuild b/dev-tcltk/tcl3d/tcl3d-0.5.0.ebuild
index e9a64f8be868..1b0775851245 100644
--- a/dev-tcltk/tcl3d/tcl3d-0.5.0.ebuild
+++ b/dev-tcltk/tcl3d/tcl3d-0.5.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,26 +12,25 @@ SRC_URI="http://www.tcl3d.org/download/${P}.distrib/${PN}-src-${PV}.zip"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug"
+IUSE="debug ode osg sdl truetype"
-DEPEND="
- >=dev-lang/swig-1.3.38:0=
+RDEPEND="dev-lang/tcl:0=
dev-lang/tk:0=
- dev-lang/tcl:0=
- dev-games/ode
- dev-games/openscenegraph
- media-libs/libsdl
- media-libs/ftgl
- virtual/opengl
+ x11-libs/libXi
x11-libs/libXmu
-"
+ virtual/opengl
+ virtual/glu
+ ode? ( dev-games/ode )
+ osg? ( dev-games/openscenegraph )
+ truetype? ( media-libs/ftgl )
+ sdl? ( media-libs/libsdl )"
+DEPEND="${RDEPEND}
+ >=dev-lang/swig-1.3.38:0="
S="${WORKDIR}/${PN}"
PATCHES=( "${FILESDIR}/${P}-include-tk-dir-and-permissive.patch" )
-src_prepare() {
- default
-
+src_configure() {
local _TCL_V=( $(echo 'puts [info tclversion]' | tclsh | tr '.' ' ') )
local _TCL_FV="${_TCL_V[0]}.${_TCL_V[1]}"
@@ -49,6 +48,13 @@ src_compile() {
append-flags -fPIC
use debug || append-flags -DNDEBUG
+ # Configure wrapper
+ local CONFIG_PLUGIN="WRAP_GL2PS="
+ use truetype || CONFIG_PLUGIN+=" WRAP_FTGL="
+ use ode || CONFIG_PLUGIN+=" WRAP_ODE="
+ use osg || CONFIG_PLUGIN+=" WRAP_OSG="
+ use sdl || CONFIG_PLUGIN+=" WRAP_SDL="
+
# Restricting build to -j1 since it seems that if we build it in parallel,
# it fails with the "tcl3dOsg" project attempting to import glewdefs.i,
# and not finding it.
@@ -59,10 +65,7 @@ src_compile() {
CC="$(tc-getCC) -c" \
CXX="$(tc-getCXX) -c" \
LD="$(tc-getLD)" \
- WRAP_FTGL=1 \
- WRAP_SDL=1 \
- WRAP_GL2PS=0 \
- WRAP_ODE=1
+ ${CONFIG_PLUGIN}
}
src_install() {