summaryrefslogtreecommitdiff
path: root/dev-tcltk/expect/expect-5.45.4-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /dev-tcltk/expect/expect-5.45.4-r4.ebuild
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'dev-tcltk/expect/expect-5.45.4-r4.ebuild')
-rw-r--r--dev-tcltk/expect/expect-5.45.4-r4.ebuild80
1 files changed, 0 insertions, 80 deletions
diff --git a/dev-tcltk/expect/expect-5.45.4-r4.ebuild b/dev-tcltk/expect/expect-5.45.4-r4.ebuild
deleted file mode 100644
index ba137b0db314..000000000000
--- a/dev-tcltk/expect/expect-5.45.4-r4.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools edo flag-o-matic
-
-MY_P="${PN}${PV}"
-DESCRIPTION="tool for automating interactive applications"
-HOMEPAGE="https://core.tcl-lang.org/expect/"
-SRC_URI="https://downloads.sourceforge.net/${PN}/${MY_P}.tar.gz"
-S="${WORKDIR}"/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
-IUSE="debug doc test threads"
-RESTRICT="!test? ( test )"
-
-DEPEND=">=dev-lang/tcl-8.2:=[threads?]"
-RDEPEND="${DEPEND}"
-BDEPEND="test? ( dev-util/dejagnu )"
-
-PATCHES=( "${FILESDIR}"/${P}-examples.patch )
-
-src_prepare() {
- default
- sed -i "s:/usr/local/bin:${EPREFIX}/usr/bin:" expect.man || die
-
- eapply "${FILESDIR}"/${PN}-5.45-gfbsd.patch
- eapply "${FILESDIR}"/${PN}-5.44.1.15-ldflags.patch
- eapply "${FILESDIR}"/${PN}-5.45-headers.patch #337943
- eapply "${FILESDIR}"/${PN}-5.45-format-security.patch
- eapply "${FILESDIR}"/${PN}-5.45.4-configure-in.patch
- eapply "${FILESDIR}"/${PN}-5.45.4-configure-clang16.patch || die
-
- sed -i 's:ifdef HAVE_SYS_WAIT_H:ifndef NO_SYS_WAIT_H:' *.c || die
-
- # fix install_name on darwin
- [[ ${CHOST} == *-darwin* ]] && \
- eapply "${FILESDIR}"/${P}-darwin-install_name.patch
-
- mv configure.{in,ac} || die
-
- eautoconf
-}
-
-src_configure() {
- # bug #881687
- append-flags -std=gnu89
-
- # the 64bit flag is useless ... it only adds 64bit compiler flags
- # (like -m64) which the target toolchain should already handle
- econf \
- --cache-file="${S}"/config.cache \
- --with-tcl="${EPREFIX}/usr/$(get_libdir)" \
- --disable-64bit \
- --enable-shared \
- $(use_enable threads) \
- $(use_enable debug symbols mem)
-}
-
-expect_make_var() {
- touch pkgIndex.tcl-hand || die
- printf 'all:;echo $('$1')\ninclude Makefile' | emake --no-print-directory -s -f -
- rm -f pkgIndex.tcl-hand || die
-}
-
-src_install() {
- default
-
- if use doc ; then
- docinto examples
-
- edo dodoc \
- example/README \
- $(printf 'example/%s ' $(expect_make_var _SCRIPTS)) \
- $(printf 'example/%s.man ' $(expect_make_var _SCRIPTS_MANPAGES))
- fi
-}