summaryrefslogtreecommitdiff
path: root/dev-scheme/stklos/stklos-1.70-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-30 15:46:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-10-30 15:46:36 +0000
commit691395139ec5ea80983f870451c53bb6fff8298a (patch)
tree6a38689d6e69bebf65189be0d9d4e1c73ff7f4da /dev-scheme/stklos/stklos-1.70-r1.ebuild
parent310615add7b4be144ba0a7d7a156fe2c7949116d (diff)
gentoo auto-resync : 30:10:2023 - 15:46:36
Diffstat (limited to 'dev-scheme/stklos/stklos-1.70-r1.ebuild')
-rw-r--r--dev-scheme/stklos/stklos-1.70-r1.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-scheme/stklos/stklos-1.70-r1.ebuild b/dev-scheme/stklos/stklos-1.70-r1.ebuild
deleted file mode 100644
index af8d4da1cbde..000000000000
--- a/dev-scheme/stklos/stklos-1.70-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="8"
-
-inherit autotools toolchain-funcs
-
-DESCRIPTION="Fast and light Scheme implementation"
-HOMEPAGE="https://www.stklos.net/"
-SRC_URI="https://www.${PN}.net/download/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="threads"
-
-RDEPEND="dev-libs/boehm-gc[threads?]
- dev-libs/gmp:=
- dev-libs/libffi:=
- dev-libs/libpcre"
-DEPEND="${RDEPEND}"
-
-DOCS=( AUTHORS ChangeLog {HACKING,NEWS}.md PACKAGES-USED {PORTING-NOTES,README}.md SUPPORTED-SRFIS )
-
-PATCHES=(
- "${FILESDIR}"/${P}-gentoo.patch
- "${FILESDIR}"/${P}-configure-clang16.patch
-)
-
-src_prepare() {
- default
-
- use threads || rm -f tests/srfis/216.stk
-
- eautoreconf
-}
-
-src_configure() {
- export LD="$(tc-getCC)"
-
- econf \
- --enable-threads=$(usex threads pthreads none) \
- --without-gmp-light \
- --without-provided-ffi \
- --without-provided-gc \
- --without-provided-regexp
-}
-
-src_compile() {
- emake -j1
-}
-
-src_test() {
- emake -j1 check
-}
-
-src_install() {
- default
- einstalldocs
-}