summaryrefslogtreecommitdiff
path: root/dev-scheme/gambit/gambit-4.9.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-scheme/gambit/gambit-4.9.3-r2.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-scheme/gambit/gambit-4.9.3-r2.ebuild')
-rw-r--r--dev-scheme/gambit/gambit-4.9.3-r2.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-scheme/gambit/gambit-4.9.3-r2.ebuild b/dev-scheme/gambit/gambit-4.9.3-r2.ebuild
new file mode 100644
index 000000000000..76a2291343a4
--- /dev/null
+++ b/dev-scheme/gambit/gambit-4.9.3-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common
+
+MY_PV="${PV//./_}"
+MY_P="${PN}-v${MY_PV}"
+
+DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter"
+HOMEPAGE="http://www.iro.umontreal.ca/~gambit/"
+SRC_URI="http://www-labs.iro.umontreal.ca/~gambit/download/gambit/v${PV%.*}/source/${MY_P}.tgz"
+
+LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/ghostscript-gpl
+ emacs? ( >=app-editors/emacs-23.1:* )
+"
+
+SITEFILE="50gambit-gentoo.el"
+
+S="${WORKDIR}/${MY_P}" #-devel
+
+IUSE="emacs ssl static"
+
+src_configure() {
+ econf \
+ $(use_enable !static shared) \
+ $(use_enable ssl openssl) \
+ --enable-gnu-gcc-specific-options \
+ --enable-gnu-gcc-no-strict-aliasing \
+ --enable-single-host \
+ --disable-absolute-shared-libs \
+ --enable-type-checking
+}
+
+src_compile() {
+ emake bootstrap
+
+ if use emacs; then
+ elisp-compile misc/*.el || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ keepdir /usr/share/"${MY_PN}"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}