summaryrefslogtreecommitdiff
path: root/dev-scheme/chez/chez-10.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-30 08:00:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-30 08:00:51 +0100
commitd5ee59790ee8298b8599b0aa0fa21a98b972a44d (patch)
tree2cc4393cdcfae28879cee110e5975f6e6b798f91 /dev-scheme/chez/chez-10.0.0.ebuild
parentd855918b46ba8714cf1320fe63b55fd0ed1748a6 (diff)
gentoo auto-resync : 30:06:2024 - 08:00:50
Diffstat (limited to 'dev-scheme/chez/chez-10.0.0.ebuild')
-rw-r--r--dev-scheme/chez/chez-10.0.0.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-scheme/chez/chez-10.0.0.ebuild b/dev-scheme/chez/chez-10.0.0.ebuild
index c7b445a4a130..125542683907 100644
--- a/dev-scheme/chez/chez-10.0.0.ebuild
+++ b/dev-scheme/chez/chez-10.0.0.ebuild
@@ -17,7 +17,7 @@ S="${WORKDIR}/csv${PV//a}"
LICENSE="Apache-2.0 MIT"
SLOT="0/${PV}"
KEYWORDS="amd64 ~arm ~x86"
-IUSE="X ncurses threads"
+IUSE="X +ncurses +threads"
# "some output differs from expected", needs in-depth investigation.
RESTRICT="test"
@@ -54,13 +54,16 @@ src_prepare() {
src_configure() {
# See official docs for translation guide.
- # https://cisco.github.io/ChezScheme/release_notes/v9.6/release_notes.html
- # "t" for threading + arch_map + "le" for Linux (hardcoded for now)
+ # https://cisco.github.io/ChezScheme/release_notes/v10.0/release_notes.html
+ # "t" for threading + arch_map + "le" for Linux
local -A arch_map=(
+ [x86]=i3
[amd64]=a6
+ [arm64]=arm64
[arm]=arm32
+ [riscv]=rv64
+ [loong]=la64
[ppc]=ppc32
- [x86]=i3
)
local machine="$(usex threads 't' '')${arch_map[${ARCH}]}le"