summaryrefslogtreecommitdiff
path: root/dev-scheme/bytestructures/bytestructures-2.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-16 16:07:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-16 16:07:12 +0100
commitaa0b5f37afc4a88422d6301d07e4e3852ddd7251 (patch)
tree342a70a4619ad0ebf69d8cb04c1a42e5006af4d9 /dev-scheme/bytestructures/bytestructures-2.0.1.ebuild
parent11263cb7c372230b9e5c0195c24692e299887573 (diff)
gentoo auto-resync : 16:05:2023 - 16:07:12
Diffstat (limited to 'dev-scheme/bytestructures/bytestructures-2.0.1.ebuild')
-rw-r--r--dev-scheme/bytestructures/bytestructures-2.0.1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-scheme/bytestructures/bytestructures-2.0.1.ebuild b/dev-scheme/bytestructures/bytestructures-2.0.1.ebuild
index 165c1a44eda8..3412c6595c4b 100644
--- a/dev-scheme/bytestructures/bytestructures-2.0.1.ebuild
+++ b/dev-scheme/bytestructures/bytestructures-2.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,7 +13,6 @@ S="${WORKDIR}/scheme-${PN}-${PV}"
LICENSE="LGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RESTRICT="strip"
RDEPEND=">=dev-scheme/guile-2.0.0:="
DEPEND="${RDEPEND}"
@@ -29,3 +28,11 @@ src_prepare() {
# http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
find "${S}" -name "*.scm" -exec touch {} + || die
}
+
+src_install() {
+ default
+
+ # Workaround llvm-strip problem of mangling guile ELF debug
+ # sections: https://bugs.gentoo.org/905898
+ dostrip -x "/usr/$(get_libdir)/guile"
+}