summaryrefslogtreecommitdiff
path: root/dev-ruby
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-03 11:44:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-03 11:44:27 +0000
commit79e5685b8db7602719212510574962664af2b036 (patch)
tree9ba712c7c9bf3e76035ea6f13b256516cfb217f9 /dev-ruby
parentab5404adfda90358dfaba11eba5579f3f2b7f186 (diff)
gentoo auto-resync : 03:02:2024 - 11:44:27
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/Manifest.gzbin109086 -> 109101 bytes
-rw-r--r--dev-ruby/brotli/Manifest2
-rw-r--r--dev-ruby/brotli/brotli-0.5.0.ebuild37
-rw-r--r--dev-ruby/localhost/Manifest2
-rw-r--r--dev-ruby/localhost/localhost-1.2.0.ebuild39
-rw-r--r--dev-ruby/stringio/Manifest2
-rw-r--r--dev-ruby/stringio/stringio-3.1.0.ebuild4
7 files changed, 84 insertions, 2 deletions
diff --git a/dev-ruby/Manifest.gz b/dev-ruby/Manifest.gz
index 8ee567e63fc9..3802384d8dba 100644
--- a/dev-ruby/Manifest.gz
+++ b/dev-ruby/Manifest.gz
Binary files differ
diff --git a/dev-ruby/brotli/Manifest b/dev-ruby/brotli/Manifest
index f9350c7f9949..9272607fbe32 100644
--- a/dev-ruby/brotli/Manifest
+++ b/dev-ruby/brotli/Manifest
@@ -1,3 +1,5 @@
DIST brotli-0.4.0.tar.gz 9460 BLAKE2B b5d5e490c3ab086d6817c1ecc9143aefe88487d65d6774bda939b25bdb6aaaea4e28d99e01d49b90dbbccceba6643c0b5fdab0cea930eaf1661454996e61fab7 SHA512 7d1d2a1343aec11e840d840358d7d27b4ef93954bc17170d581b16d46191902b6fdf6380344f0d172e5e7f3fc0948146312659a44dc95973ec30ac3344f4a656
+DIST brotli-0.5.0.tar.gz 9449 BLAKE2B daf34e3b3bc175d883a844a9fedbbe686b2b103db9249bd47d616aafd75682d381b54de9b248ef3c44ac35e4873c7046332a2c177815f597ed6f527928728c1c SHA512 ac2b9594f4a6be95417bc1d84529e2df2cd97f23a0da77ac4fa4a0253af9dc89deae8adc226609ed7dd735b899ddcc1cafeba916a7ed928484796e16b276e010
EBUILD brotli-0.4.0-r2.ebuild 874 BLAKE2B a1c0bdca9d4d9e9fbea0cb120f428a78151ef280b93325179bc60a24e97847ec2af25f7b622dc224f8a2f6d39f9cb02caf375d8c64224078c1d07293c06b6708 SHA512 6865caae1a0f242b3520c889a98dd01de0e3a99bb74e383972b84fe743b6ae3a0f597acc315ddaca852f20d042266f97eed40a8590210cfceb4922e11f50702f
+EBUILD brotli-0.5.0.ebuild 867 BLAKE2B 27f6a1eddb000cec33a589bfd57bbddc4abfe5416ac2fbc9e6763fdea56792271ce7f9d7b92d296815dd1fee8e3f0df662722b66383cd70e9ee9b43c13fd65d9 SHA512 f78771d7b5ed2deb1d2eae7a9f651a4c748d0051a3e5d3bdcb2cf60f44aed48d16b9709c2883d534d320a53f32c610a634b576327ac76bfd2491caeb4e2c7d8e
MISC metadata.xml 340 BLAKE2B 25156a37a996a4091ff75bb3cc45ba8d9fc65653fab708f0779a6606113492f0b0723b914d43e9dea4a6eb0d06325c5b4a31212b1389b82f845ef1a541a0f2fe SHA512 0b7485f8ba6fa314acda731d7f5cca43dbca1fab14cc928d2c239635b91dae19a10c2680b3c9526e6018c6f515d57ec87354e2e76ad75863408c38b9d5153ecc
diff --git a/dev-ruby/brotli/brotli-0.5.0.ebuild b/dev-ruby/brotli/brotli-0.5.0.ebuild
new file mode 100644
index 000000000000..ebec173f088d
--- /dev/null
+++ b/dev-ruby/brotli/brotli-0.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="brotli.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/brotli/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Brotli compressor/decompressor"
+HOMEPAGE="https://github.com/miyucy/brotli"
+SRC_URI="https://github.com/miyucy/brotli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+
+RDEPEND+=" >=app-arch/brotli-1.1.0"
+DEPEND+=" >=app-arch/brotli-1.1.0"
+
+# Depends on the test data in app-arch/brotli
+RESTRICT="test"
+
+all_ruby_prepare() {
+ sed -e 's/git ls-files -z -- spec/find spec -print0/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
diff --git a/dev-ruby/localhost/Manifest b/dev-ruby/localhost/Manifest
index 0708bfc22705..92c5461b3e0e 100644
--- a/dev-ruby/localhost/Manifest
+++ b/dev-ruby/localhost/Manifest
@@ -1,3 +1,5 @@
DIST localhost-1.1.10.tar.gz 2128142 BLAKE2B 06e4ab07bc273b8beba5fb3ee3f64e171a6c4a2e944c6d5e432417560283230277213732bf23ddd12e9737b2803582a11fdaa76356d14d2bdbd4e90d402c6204 SHA512 946ef247b256165cf5c849a32c0ba8dd2007164bd1549a20aca595328174709e9213ba8a98448dc41a57558b00147c3b7428b7bc625059ab24f89c94ff8850e9
+DIST localhost-1.2.0.tar.gz 2128359 BLAKE2B 793e43779ec0b1392104914d9adc1d468820f54b920a8ec4e4f538b313e607a6016a0d2d7b8db242571bdd561161bd71ef781eae310d1f57005c2b0a0fa5c5b4 SHA512 f60cf31a31ac43962e98e933955973ce4bdf76252e43ee3ef969fe104fb71bc5d2faa3213c93532acba28650cd453663785c15b33eed65309f8c235ce116b70d
EBUILD localhost-1.1.10.ebuild 1021 BLAKE2B 5c5c55becbeb18825f4223f9931fa88f5280f39ace70d7c9bc769e5c0e7976cff214d2ad55bd32d6ceae87267c9064e3a018b2e4c90a1ebf855e58f9f063df18 SHA512 0f7244840cae1f89fdb2a59a0bf0d4b77e6c3f1c206ab73a6a7135342aa17eb1b2b8237569903a6f3c8af7f445fd7fef3d44b6a9e63f4f2c4dbcce986f743fec
+EBUILD localhost-1.2.0.ebuild 1009 BLAKE2B ac4e052c0c775f4e8abb3a304e028af07905ededcbd6e19f72c38a19d877028b2211292383ebc5c3c092744e2268277396a3f24f1df7d6b6f3cbe5926280af3a SHA512 f39781c81ac366d29744752b4dd3c555e24a804e813c5b95f0e85a4749c9a6f51d69005a1f0baa487fda7babb1d730316ab70113cababe1ff514c1a467d1685b
MISC metadata.xml 329 BLAKE2B 7254a554334f253b54f3d5673d55f247298a55fbc677b916de26a3a93bc2866836d1e0bc5a5e3692605c364852fe007a285b6b02d1953b0b0cac2ff86b83a5d0 SHA512 32a7e4b5cd3fe72608fe629be5fd057a1e184bfe584f3bddb9be087566141b550d1a407ba20f9afb50d06af694945d6687115f785585c2b88a546dd31ada8297
diff --git a/dev-ruby/localhost/localhost-1.2.0.ebuild b/dev-ruby/localhost/localhost-1.2.0.ebuild
new file mode 100644
index 000000000000..3d7b9f9412c2
--- /dev/null
+++ b/dev-ruby/localhost/localhost-1.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="readme.md"
+RUBY_FAKEGEM_GEMSPEC="localhost.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="sus"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Manage a local CA for self-signed localhost development servers"
+HOMEPAGE="https://github.com/socketry/localhost"
+SRC_URI="https://github.com/socketry/localhost/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/async-io
+ dev-ruby/async-process
+ dev-ruby/sus-fixtures-async
+ )
+"
+
+all_ruby_prepare() {
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/covered/Id' config/sus.rb || die
+}
+
+each_ruby_test() {
+ # Tests fail in parallel as it tries to use the same port so
+ # manually replicate ruby-ng_sus for now, as ruby-ng_sus runs sus-parallel.
+ ${RUBY} -S sus || die
+}
diff --git a/dev-ruby/stringio/Manifest b/dev-ruby/stringio/Manifest
index e31e4b1cbe47..1d5f0b0e3b98 100644
--- a/dev-ruby/stringio/Manifest
+++ b/dev-ruby/stringio/Manifest
@@ -3,5 +3,5 @@ DIST stringio-3.0.9.tar.gz 34991 BLAKE2B e047831dc0c88732b9939cfb7f5df97aceeeff1
DIST stringio-3.1.0.tar.gz 34946 BLAKE2B 4478e6493eb96be48c3f36830948e9b554474200a8738b5e4ab98d38fcc9f429a7b52cff553c0639fd8e30da2699802f5e1c385e51ab5965b0486ae9d0a44879 SHA512 d980566af84645700ad8450ef770ba2444ae7fb9f18cb33b141be0905536bcd639ec619aa535746109777f2f837727103280d80f2ff32fc8a22461a442f09e5a
EBUILD stringio-3.0.7.ebuild 912 BLAKE2B f66947230f3091daa94578cce02b7c341259e9fec883544fd6ccd0e921c7024e54323d6938b9590976ddec1e2f87b2e473e7e13c0b9e0d1c5f8e7abe0dade46a SHA512 35e147a8246b79a360d74e5c036f64480f2703a2fd67984de8fbfb10ef07eeb4fa2bee96748031c1ceb91a4e64414a8c701ca582c492f4a1bee76cbd1f87dda9
EBUILD stringio-3.0.9.ebuild 892 BLAKE2B fdb6ba89253749db27545934f660130cf3397ca83ab53dce5afd09fb312f3ec74cba3444435479c348337650fe89d838efab288b57046e3cf07d91f5546a8be2 SHA512 96688fa57e457d19bdb1bf6b7570183c5875e45a1bf474f1c4d56e18c36ad450110ba2d5d62fecfbbf63afa65a29eb0ffead0d2119cef7d3ad5c395aa51a969c
-EBUILD stringio-3.1.0.ebuild 920 BLAKE2B 697b08b8ed5d96da2148d9d95fc3368b3d5efebca7e19adcd932d926875f4ae651ed69a320a0b60072c2381e53f6b30d910bbcc3c8b20368709a626a24acf8af SHA512 4db54c1941f9fc4d84d254d41db0b5e3c9429735484bc420fcf853709c1ce4215e68020994a6f3b81816fcb7a2b8194fef1cd60c100f10402a7bd327e931b5df
+EBUILD stringio-3.1.0.ebuild 998 BLAKE2B d4db0843936034e1363c0a4335918d1739fb62de7e3c53323d2c16e9eea02b74d2bad2ac0343c6318c9ba3684728ed4cc16d1bc91efb0fe6d64ac90f3bdb846b SHA512 e471dbd6358bf7133c8c8e939cc1c2fe9e245beedc28c38cce679bd04f76cd8701efa5c0b3d1d9497abbd2d94de38168e3e8d2905d471221f3c0cce8d8e8efd0
MISC metadata.xml 340 BLAKE2B bd5f8222a43eb391d2d14a1b878fadefd9f8a322e87b5058d482df79d95d70f7ef19c54e7ae12dc29e7ffc84c72e630f0ca46ac095059263cdcf6047cb4fa4d9 SHA512 f1f32d2c4c13e19500a7ff23b684b180d3dba8a79e49b8cb57b80e265d09e06cb8b7a9e6b743158a140967b7ccbb991fdf51cb3a6e95be4e24378a5f85efcbb2
diff --git a/dev-ruby/stringio/stringio-3.1.0.ebuild b/dev-ruby/stringio/stringio-3.1.0.ebuild
index b5d844a9a06f..d8350c676f2d 100644
--- a/dev-ruby/stringio/stringio-3.1.0.ebuild
+++ b/dev-ruby/stringio/stringio-3.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -19,6 +19,8 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390
SLOT="0"
IUSE="test"
+ruby_add_bdepend "test? ( dev-ruby/test-unit dev-ruby/test-unit-ruby-core )"
+
all_ruby_prepare() {
sed -e "/s.version =/ s/source_version/'${PV}'/" \
-e 's/__dir__/"."/' \