summaryrefslogtreecommitdiff
path: root/dev-ruby
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-18 15:36:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-18 15:36:15 +0100
commita2f7cdda45fadf1f967379421e8d808b1a503cd3 (patch)
treec02c7db0bb9249243aa73a4098a17e13daaaff21 /dev-ruby
parent66611e742171c343d64095516e19737d4753ba61 (diff)
gentoo auto-resync : 18:08:2023 - 15:36:15
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/Manifest.gzbin106258 -> 106576 bytes
-rw-r--r--dev-ruby/ipaddr/Manifest3
-rw-r--r--dev-ruby/ipaddr/ipaddr-1.2.5.ebuild31
-rw-r--r--dev-ruby/ipaddr/metadata.xml11
-rw-r--r--dev-ruby/stream/Manifest3
-rw-r--r--dev-ruby/stream/metadata.xml11
-rw-r--r--dev-ruby/stream/stream-0.5.5.ebuild21
7 files changed, 80 insertions, 0 deletions
diff --git a/dev-ruby/Manifest.gz b/dev-ruby/Manifest.gz
index 5943e4d408bf..4148e9773783 100644
--- a/dev-ruby/Manifest.gz
+++ b/dev-ruby/Manifest.gz
Binary files differ
diff --git a/dev-ruby/ipaddr/Manifest b/dev-ruby/ipaddr/Manifest
new file mode 100644
index 000000000000..01813b34956e
--- /dev/null
+++ b/dev-ruby/ipaddr/Manifest
@@ -0,0 +1,3 @@
+DIST ipaddr-1.2.5.tar.gz 21795 BLAKE2B dfc4d50941dc9275ff45bcd35ac48ea678c6d6bd4e4227e5514ba7ba1ad2bde7e6692eb81dfc066332211fa20911c58573d9e6fd6842195cebea69f004cf4dd1 SHA512 d3741e6841ad78dba364227d7f0313843068c06dd13f2f459cc3c07e5f2a9ed7d9a9ebbeb2533235ba561a52966bbfc78375b8b0ab36a9275a49251658c6deab
+EBUILD ipaddr-1.2.5.ebuild 953 BLAKE2B 21b13f0e478799b5e0499ee5f98089ab73d42d8871d963e7c1f4ef944f3aae23b461eb3e87ab0f9f4f07cc3784734e5f1d026b81a635da17c588a181acd3c4bd SHA512 9aea8bf0111b64a24c124333a61ddaac2e0dedeb8ad7a3b195fb35d5a53873f0c281def3c588e622e6f138785d92431eff6d6e3a7135b761ac4ff3ebea4060c9
+MISC metadata.xml 338 BLAKE2B cd42f6b9da9119c3e5c260ecd9aec64ad09dccc847e4720297bbd06a72a5bd9c17f83d99a4bd52ce7969bd5c9eb6cf3a54cf874a2f1c19c676730d87d39b8c7d SHA512 912bc07f88a2b215c2ada62db4c422e71b5a83450e36d88f76dc56ca5f9165401565e4fd1728c747b6be12e8b0e0eba003cd8b06687b2679206b22370a1149db
diff --git a/dev-ruby/ipaddr/ipaddr-1.2.5.ebuild b/dev-ruby/ipaddr/ipaddr-1.2.5.ebuild
new file mode 100644
index 000000000000..befd16d48786
--- /dev/null
+++ b/dev-ruby/ipaddr/ipaddr-1.2.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="ipaddr.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="IPAddr provides a set of methods to manipulate an IPv4 or IPv6 address"
+HOMEPAGE="https://github.com/ruby/ipaddr"
+SRC_URI="https://github.com/ruby/ipaddr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test:test/lib -rhelper -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}
diff --git a/dev-ruby/ipaddr/metadata.xml b/dev-ruby/ipaddr/metadata.xml
new file mode 100644
index 000000000000..0057dde65dce
--- /dev/null
+++ b/dev-ruby/ipaddr/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby/ipaddr</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/stream/Manifest b/dev-ruby/stream/Manifest
new file mode 100644
index 000000000000..11c10196a06e
--- /dev/null
+++ b/dev-ruby/stream/Manifest
@@ -0,0 +1,3 @@
+DIST stream-0.5.5.tar.gz 11828 BLAKE2B daba14d60c8978fbd7dd57eb9bc61362634ab414b2c8a88065251acbcc65beec1aa11db5f65fd09e37d0fe6abb904f4dbdcb6a1a9b58cf8c757cb90359d377c6 SHA512 bf9f48201b70f30caa9b9c4240254ff78e6e4dd760475ec23fe95d77e42cfa41b6bb43a19c2469ec8554bee8b6aafd84a3c830651b26b9602b53cdec57d976b1
+EBUILD stream-0.5.5.ebuild 570 BLAKE2B cf1e07d9de8797f7d6456d3500b89be29bce64279a510e1bb36da9b21d1d09c90f2d85bb900b94a08311456fa90447b89b877b140cd23056fb835413a2869ea4 SHA512 d2d82cdcc7745c01228f1fdc788de4ef3a6172169b1e461fc197079904832aa186bd7466a868b81d2afc03d1dc7695d91d6369d077ecc1d9383e21c80712c1fa
+MISC metadata.xml 340 BLAKE2B f7e18b3ce609fe3f682e57793acd9ae765f26f85d3e0e0e57903d06a0c021d2cb4d5c6e2921407f554bef30b2f6a7a278794d688daacc156c23270306dec1861 SHA512 b353ad98e923ac210bda32c0170dc04ff962b1c97e7fa9c309ac54d6dc0c960887a47913ea3dd390a1603bf37f1139b61a2eadaf6f2dae9f8e2efdb77f8efeb9
diff --git a/dev-ruby/stream/metadata.xml b/dev-ruby/stream/metadata.xml
new file mode 100644
index 000000000000..d0db85479c40
--- /dev/null
+++ b/dev-ruby/stream/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">monora/stream</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/stream/stream-0.5.5.ebuild b/dev-ruby/stream/stream-0.5.5.ebuild
new file mode 100644
index 000000000000..8b443a3dbcc1
--- /dev/null
+++ b/dev-ruby/stream/stream-0.5.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+RUBY_FAKEGEM_GEMSPEC="stream.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Module Stream defines an interface for external iterators"
+HOMEPAGE="https://github.com/monora/stream"
+SRC_URI="https://github.com/monora/stream/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "dev-ruby/bundler dev-ruby/yard test? ( dev-ruby/test-unit )"