summaryrefslogtreecommitdiff
path: root/dev-ruby/xml-simple
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/xml-simple
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/xml-simple')
-rw-r--r--dev-ruby/xml-simple/Manifest3
-rw-r--r--dev-ruby/xml-simple/metadata.xml11
-rw-r--r--dev-ruby/xml-simple/xml-simple-1.1.5.ebuild26
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/xml-simple/Manifest b/dev-ruby/xml-simple/Manifest
new file mode 100644
index 000000000000..83d93e2715ee
--- /dev/null
+++ b/dev-ruby/xml-simple/Manifest
@@ -0,0 +1,3 @@
+DIST xml-simple-1.1.5.tar.gz 126288 BLAKE2B 0fb7f8cebee23e422d2941de790426e494bce51af90cda8a3b7f3b27129f6272aa277a80fce004aca2658d5ae5f62b7aa9f251b53839d14e6d5b7f5a33b819af SHA512 df81a05a0c32141cb5a0328fb782292438ec3ad6037c150e2ff4fee07b65ba9a739987f25f28c196ff8565af53c62120c3a729820a94dd3da0551fe43948f9a3
+EBUILD xml-simple-1.1.5.ebuild 650 BLAKE2B e68edb7523d1c8424974910ee35a6cd8b1660f2d03187d82cfa1ecbc0cbdc69da1b975aa6b47fb3789388b742b27e8b2bb2fa5e6565cf29dc3ee7804562f17a6 SHA512 da0b8c54ab9cdcbc82b27abae8fffab8c79e20342de9ccb0ed8641f71a1cdc11453a7fa5fe0a08e9ba801528d17235a1545021dc91ae303195fb1fe85931e03f
+MISC metadata.xml 341 BLAKE2B 0a68913e95e2a3d74b65bb6cb19bd59f0e9c6c7a074e653ab420f641441c27c24f3932a03a279242ef43d718084db94ab3ba23bc101c11a0aae3fbe57e9a5acf SHA512 db7faacf3407eaac7956d64cbe073e4a86a040af4ecf275c47cd532fae8f9331710cb8da857a6feb2d8bf58570ce6f633414790c2a5f7df268382db539987177
diff --git a/dev-ruby/xml-simple/metadata.xml b/dev-ruby/xml-simple/metadata.xml
new file mode 100644
index 000000000000..931db2a32b71
--- /dev/null
+++ b/dev-ruby/xml-simple/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">maik/xml-simple</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/xml-simple/xml-simple-1.1.5.ebuild b/dev-ruby/xml-simple/xml-simple-1.1.5.ebuild
new file mode 100644
index 000000000000..bd7920deadb4
--- /dev/null
+++ b/dev-ruby/xml-simple/xml-simple-1.1.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+# Gem only contains lib code, and github repository has no tags.
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/maik/xml-simple/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="Easy API to maintain XML. A Ruby port of Grant McLean's Perl module XML::Simple"
+HOMEPAGE="https://github.com/maik/xml-simple"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~x86"
+IUSE=""
+
+each_ruby_test() {
+ cd test || die
+ for i in *.rb; do
+ ${RUBY} -I../lib ${i} || die
+ done
+}