summaryrefslogtreecommitdiff
path: root/dev-ruby/xml-simple/xml-simple-1.1.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/xml-simple/xml-simple-1.1.5.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/xml-simple/xml-simple-1.1.5.ebuild')
-rw-r--r--dev-ruby/xml-simple/xml-simple-1.1.5.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/xml-simple/xml-simple-1.1.5.ebuild b/dev-ruby/xml-simple/xml-simple-1.1.5.ebuild
new file mode 100644
index 000000000000..bd7920deadb4
--- /dev/null
+++ b/dev-ruby/xml-simple/xml-simple-1.1.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+# Gem only contains lib code, and github repository has no tags.
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/maik/xml-simple/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="Easy API to maintain XML. A Ruby port of Grant McLean's Perl module XML::Simple"
+HOMEPAGE="https://github.com/maik/xml-simple"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~x86"
+IUSE=""
+
+each_ruby_test() {
+ cd test || die
+ for i in *.rb; do
+ ${RUBY} -I../lib ${i} || die
+ done
+}