summaryrefslogtreecommitdiff
path: root/dev-ruby/x25519/x25519-1.0.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-ruby/x25519/x25519-1.0.9.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-ruby/x25519/x25519-1.0.9.ebuild')
-rw-r--r--dev-ruby/x25519/x25519-1.0.9.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/x25519/x25519-1.0.9.ebuild b/dev-ruby/x25519/x25519-1.0.9.ebuild
new file mode 100644
index 000000000000..f00eb3f62157
--- /dev/null
+++ b/dev-ruby/x25519/x25519-1.0.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="x25519.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/x25519_ref10/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Key exchange via the X25519 (Curve25519) Elliptic Curve Diffie-Hellman function"
+HOMEPAGE="https://github.com/crypto-rb/x25519"
+SRC_URI="https://github.com/crypto-rb/x25519/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#: ; /coverall/I s:^:#:' spec/spec_helper.rb || die
+
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # The precomputed implementation only works on amd64
+ if use amd64 ; then
+ RUBY_FAKEGEM_EXTENSIONS+=(ext/x25519_precomputed/extconf.rb)
+ else
+ sed -i -e '/\(x25519_precomputed\|X25519::Provider::Precomputed\)/ s:^:#:' lib/x25519.rb || die
+ rm -f spec/x25519/provider/precomputed_spec.rb || die
+ fi
+}