summaryrefslogtreecommitdiff
path: root/dev-ruby/x25519/x25519-1.0.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /dev-ruby/x25519/x25519-1.0.8.ebuild
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'dev-ruby/x25519/x25519-1.0.8.ebuild')
-rw-r--r--dev-ruby/x25519/x25519-1.0.8.ebuild17
1 files changed, 14 insertions, 3 deletions
diff --git a/dev-ruby/x25519/x25519-1.0.8.ebuild b/dev-ruby/x25519/x25519-1.0.8.ebuild
index 36e65576f661..cd2b4a702e7f 100644
--- a/dev-ruby/x25519/x25519-1.0.8.ebuild
+++ b/dev-ruby/x25519/x25519-1.0.8.ebuild
@@ -26,16 +26,27 @@ all_ruby_prepare() {
sed -i -e '/bundler/ s:^:#: ; /coverall/I s:^:#:' spec/spec_helper.rb || die
sed -i -e 's/git ls-files -z/find . -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # The precomputed implementation only works on amd64
+ if ! use amd64 ; then
+ sed -i -e '/\(x25519_precomputed\|X25519::Provider::Precomputed\)/ s:^:#:' lib/x25519.rb || die
+ fi
}
each_ruby_configure() {
- ${RUBY} -Cext/x25519_precomputed extconf.rb || die
+ if use amd64 ; then
+ ${RUBY} -Cext/x25519_precomputed extconf.rb || die
+ fi
+
${RUBY} -Cext/x25519_ref10 extconf.rb || die
}
each_ruby_compile() {
- emake V=1 -Cext/x25519_precomputed
- cp ext/x25519_precomputed/x25519_precomputed.so lib/ || die
+ if use amd64 ; then
+ emake V=1 -Cext/x25519_precomputed
+ cp ext/x25519_precomputed/x25519_precomputed.so lib/ || die
+ fi
+
emake V=1 -Cext/x25519_ref10
cp ext/x25519_ref10/x25519_ref10.so lib/ || die
}