summaryrefslogtreecommitdiff
path: root/dev-ruby/windows_error/windows_error-0.1.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-25 14:07:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-25 14:07:44 +0000
commit6a84e414622fd99c22318ce656a77bb2a0433fc7 (patch)
tree048f41d4a2a9c373e50bf0906c5508e6f5104fae /dev-ruby/windows_error/windows_error-0.1.5.ebuild
parenta1b20429e7e2ba1b44414459afd5a2b50788cd9c (diff)
gentoo auto-resync : 25:01:2023 - 14:07:44
Diffstat (limited to 'dev-ruby/windows_error/windows_error-0.1.5.ebuild')
-rw-r--r--dev-ruby/windows_error/windows_error-0.1.5.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/windows_error/windows_error-0.1.5.ebuild b/dev-ruby/windows_error/windows_error-0.1.5.ebuild
new file mode 100644
index 000000000000..61a07d8c514e
--- /dev/null
+++ b/dev-ruby/windows_error/windows_error-0.1.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="reference for standard Windows API Error Codes"
+HOMEPAGE="https://github.com/rapid7/windows_error"
+
+LICENSE="BSD"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ rm -f .rspec || die
+}