summaryrefslogtreecommitdiff
path: root/dev-ruby/will_paginate/will_paginate-4.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-08 22:23:22 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-08 22:23:22 +0100
commit99b2c44c1425c7b2925846d4c44b2bf2f78dc786 (patch)
tree9bf7a2d385aace0ea5f3f8d3e3657168b758fdaa /dev-ruby/will_paginate/will_paginate-4.0.0.ebuild
parent39bccce90513402ec93bb0fde30678f16b07a9cc (diff)
gentoo auto-resync : 08:07:2023 - 22:23:22
Diffstat (limited to 'dev-ruby/will_paginate/will_paginate-4.0.0.ebuild')
-rw-r--r--dev-ruby/will_paginate/will_paginate-4.0.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/will_paginate/will_paginate-4.0.0.ebuild b/dev-ruby/will_paginate/will_paginate-4.0.0.ebuild
new file mode 100644
index 000000000000..d108591d7aad
--- /dev/null
+++ b/dev-ruby/will_paginate/will_paginate-4.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="will_paginate.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Most awesome pagination solution for Ruby"
+HOMEPAGE="https://github.com/mislav/will_paginate/"
+SRC_URI="https://github.com/mislav/will_paginate/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ # Remove tests for unpackaged ORMs
+ rm -f spec/finders/{sequel,mongoid,data_mapper}* || die
+}
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/rails
+ dev-ruby/sqlite3
+ dev-ruby/mocha
+ )"