summaryrefslogtreecommitdiff
path: root/dev-ruby/will_paginate/will_paginate-3.1.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /dev-ruby/will_paginate/will_paginate-3.1.7.ebuild
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'dev-ruby/will_paginate/will_paginate-3.1.7.ebuild')
-rw-r--r--dev-ruby/will_paginate/will_paginate-3.1.7.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/will_paginate/will_paginate-3.1.7.ebuild b/dev-ruby/will_paginate/will_paginate-3.1.7.ebuild
new file mode 100644
index 000000000000..459c8b5f9558
--- /dev/null
+++ b/dev-ruby/will_paginate/will_paginate-3.1.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Most awesome pagination solution for Ruby"
+HOMEPAGE="https://github.com/mislav/will_paginate/"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~x86-macos"
+IUSE=""
+
+all_ruby_prepare() {
+ # Remove tests for unpackaged ORMs
+ rm -f spec/finders/{sequel,mongoid,data_mapper}* || die
+}
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/rails
+ dev-ruby/mocha
+ )"