summaryrefslogtreecommitdiff
path: root/dev-ruby/warden/warden-1.2.9-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /dev-ruby/warden/warden-1.2.9-r1.ebuild
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'dev-ruby/warden/warden-1.2.9-r1.ebuild')
-rw-r--r--dev-ruby/warden/warden-1.2.9-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/warden/warden-1.2.9-r1.ebuild b/dev-ruby/warden/warden-1.2.9-r1.ebuild
new file mode 100644
index 000000000000..5806b7b14cd5
--- /dev/null
+++ b/dev-ruby/warden/warden-1.2.9-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="General Rack Authentication Framework"
+HOMEPAGE="https://github.com/wardencommunity/warden"
+SRC_URI="https://github.com/wardencommunity/warden/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rack-2.0.9:*"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}