summaryrefslogtreecommitdiff
path: root/dev-ruby/vcr/vcr-2.9.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/vcr/vcr-2.9.3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/vcr/vcr-2.9.3.ebuild')
-rw-r--r--dev-ruby/vcr/vcr-2.9.3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/vcr/vcr-2.9.3.ebuild b/dev-ruby/vcr/vcr-2.9.3.ebuild
new file mode 100644
index 000000000000..5f7a9ea8c29d
--- /dev/null
+++ b/dev-ruby/vcr/vcr-2.9.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md CONTRIBUTING.md README.md Upgrade.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Records your test suite's HTTP interactions and replay them during test runs"
+HOMEPAGE="https://github.com/myronmarston/vcr/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm"
+SLOT="2"
+IUSE="test"
+
+# Tests require all supported HTTP libraries to be present, and it is
+# not possible to avoid some of them without very extensive patches.
+RESTRICT="test"