summaryrefslogtreecommitdiff
path: root/dev-ruby/unindent
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/unindent
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/unindent')
-rw-r--r--dev-ruby/unindent/Manifest3
-rw-r--r--dev-ruby/unindent/metadata.xml11
-rw-r--r--dev-ruby/unindent/unindent-1.0.ebuild24
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/unindent/Manifest b/dev-ruby/unindent/Manifest
new file mode 100644
index 000000000000..23467061a74b
--- /dev/null
+++ b/dev-ruby/unindent/Manifest
@@ -0,0 +1,3 @@
+DIST unindent-1.0.gem 6144 BLAKE2B 8720a1f6aca7da8cc8659f5a3943e9e56d15f9349efdd622857bbeffc39b04b61beb2b72a9cd337d516db2fbefd7aae02827b6705a81622ca5904dcdcc7575ad SHA512 1bab3352fc8da8b8a3ade8dff2f7c565e36529a79ca68c0a1ca73cdeca93fa507baa9399c6eed4fa020aa74dea6c4260a0242fa8057931a90bc172f138a5e655
+EBUILD unindent-1.0.ebuild 548 BLAKE2B 277d5ac36a0affb5cdfbe2da4a43f2fe23896eb28508acabab085b598ac8b0b362eff8dfb7b9931ed85cda67550653e3de8a55c802fbd656cf31d3d74e83af5b SHA512 a5d822d818c09aa64d78cbae12186a6d650df4fa9aa14899ea0ad0fe1b49b6dc1d0fb30f251947cf98289ec1812b6c465c0f0facb71cae8fb01f868bcb629d93
+MISC metadata.xml 341 BLAKE2B b95139c053f991f2430ac53d70f116c8d70757162b4bdd246283cd3e477afc58c0bb9ce2de89cdf27a7f54148f4958920b04a5066522a7f628a062a81f4bf033 SHA512 41d29de1617293949f2df18b503f931818137f002639578a75b7b6254d78f47d5b56f08ac028c37b3d399dfd8a1d63b2d3f40e22452f9a7ec8beb61c52d88e21
diff --git a/dev-ruby/unindent/metadata.xml b/dev-ruby/unindent/metadata.xml
new file mode 100644
index 000000000000..86b67396cc49
--- /dev/null
+++ b/dev-ruby/unindent/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mynyml/unindent</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/unindent/unindent-1.0.ebuild b/dev-ruby/unindent/unindent-1.0.ebuild
new file mode 100644
index 000000000000..5b4a3ed06b20
--- /dev/null
+++ b/dev-ruby/unindent/unindent-1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby method to unindent strings"
+HOMEPAGE="https://github.com/mynyml/unindent"
+LICENSE="MIT"
+
+KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ppc ppc64 sparc x86"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/nanotest )"
+
+each_ruby_test() {
+ ${RUBY} -I.:lib test/test_unindent.rb || die
+}