summaryrefslogtreecommitdiff
path: root/dev-ruby/unf/unf-0.1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-ruby/unf/unf-0.1.4.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/unf/unf-0.1.4.ebuild')
-rw-r--r--dev-ruby/unf/unf-0.1.4.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-ruby/unf/unf-0.1.4.ebuild b/dev-ruby/unf/unf-0.1.4.ebuild
deleted file mode 100644
index a33f672d0a41..000000000000
--- a/dev-ruby/unf/unf-0.1.4.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_TEST="none"
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A wrapper library to bring Unicode Normalization Form support to Ruby/JRuby"
-HOMEPAGE="https://github.com/knu/ruby-unf"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-IUSE="test"
-
-ruby_add_rdepend "dev-ruby/unf_ext"
-
-ruby_add_bdepend "
- test? (
- >=dev-ruby/test-unit-2.5.1-r1
- dev-ruby/shoulda
- )"
-
-all_ruby_prepare() {
- sed -i -e '/bundler/,/end/ d' test/helper.rb || die
-
- # Remove development dependencies; also remove platform as we don't
- # care about it as it is, they only use it to avoid the unf_ext dep
- # that we tackle on our own; finally remove git ls-files usage.
- sed -i -e '/dependency.*\(shoulda\|bundler\|jeweler\|rcov\)/d' \
- -e '/platform/d' \
- -e '/git ls/d' \
- ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-each_ruby_test() {
- ruby-ng_testrb-2 test/test_*.rb
-}