summaryrefslogtreecommitdiff
path: root/dev-ruby/unf/unf-0.1.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-ruby/unf/unf-0.1.4-r1.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-ruby/unf/unf-0.1.4-r1.ebuild')
-rw-r--r--dev-ruby/unf/unf-0.1.4-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/unf/unf-0.1.4-r1.ebuild b/dev-ruby/unf/unf-0.1.4-r1.ebuild
new file mode 100644
index 000000000000..442d4c7d5a2c
--- /dev/null
+++ b/dev-ruby/unf/unf-0.1.4-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A wrapper library to bring Unicode Normalization Form support to Ruby/JRuby"
+HOMEPAGE="https://github.com/knu/ruby-unf"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="test"
+
+ruby_add_rdepend "dev-ruby/unf_ext"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/test-unit-2.5.1-r1
+ dev-ruby/shoulda
+ )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/,/end/ d' test/helper.rb || die
+
+ # Remove development dependencies; also remove platform as we don't
+ # care about it as it is, they only use it to avoid the unf_ext dep
+ # that we tackle on our own; finally remove git ls-files usage.
+ sed -i -e '/dependency.*\(shoulda\|bundler\|jeweler\|rcov\)/d' \
+ -e '/platform/d' \
+ -e '/git ls/d' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 test/test_*.rb
+}