summaryrefslogtreecommitdiff
path: root/dev-ruby/uconv/uconv-0.6.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/uconv/uconv-0.6.1-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/uconv/uconv-0.6.1-r2.ebuild')
-rw-r--r--dev-ruby/uconv/uconv-0.6.1-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/uconv/uconv-0.6.1-r2.ebuild b/dev-ruby/uconv/uconv-0.6.1-r2.ebuild
new file mode 100644
index 000000000000..00855189d6c0
--- /dev/null
+++ b/dev-ruby/uconv/uconv-0.6.1-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+inherit ruby-ng
+
+DESCRIPTION="A module to convert ISO/IEC 10646 (Unicode) string and Japanese strings"
+HOMEPAGE="http://www.yoshidam.net/Ruby.html#uconv"
+SRC_URI="http://www.yoshidam.net/${P}.tar.gz"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ppc ppc64 x86"
+IUSE=""
+
+RUBY_S=${PN}
+
+all_ruby_prepare() {
+ sed -i -e '/^\$CFLAGS = ""/d' extconf.rb || die "Unable to remove CFLAGS line"
+}
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1
+}
+
+each_ruby_install() {
+ emake V=1 DESTDIR="${D}" install
+}
+
+all_ruby_install() {
+ dodoc README*
+}