summaryrefslogtreecommitdiff
path: root/dev-ruby/tty-command
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
commitfab849d1daed0ba7f2ac497d07985c3dbb692543 (patch)
tree10baa743a5340b42ad538dd19d48669ccac209b1 /dev-ruby/tty-command
parent73c318acdaf6f8309d68bd266051e6dd1f1bd787 (diff)
gentoo resync : 16.06.2019
Diffstat (limited to 'dev-ruby/tty-command')
-rw-r--r--dev-ruby/tty-command/Manifest3
-rw-r--r--dev-ruby/tty-command/metadata.xml11
-rw-r--r--dev-ruby/tty-command/tty-command-0.8.2.ebuild31
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/tty-command/Manifest b/dev-ruby/tty-command/Manifest
new file mode 100644
index 000000000000..bf1865026f1b
--- /dev/null
+++ b/dev-ruby/tty-command/Manifest
@@ -0,0 +1,3 @@
+DIST tty-command-0.8.2.tar.gz 30126 BLAKE2B 858b9c60380859bd984295e00638ba93416c62acbe4e5c1d0e33b411862d729c129f00dda236f4ca9943962859a35c9fe1fa2431327fb2e3170366412f8d83e3 SHA512 151af5fe0cf241b4e8004560d04fe967d8fe1d24cf311d64c4fab46d1c11b1fe27849f3925f13d3a73b7b86a55aabacd3e4bbffa9a96c34669c93b29756fe88e
+EBUILD tty-command-0.8.2.ebuild 681 BLAKE2B f8b7cbe7566f6e1598b0926d7127b77a68a1b2726ef3bc68b7bc0cbc1ddba6c8bd79220bf5eaf9de3878be600b10447fb9ece13568faa2c985e8addafc1273d7 SHA512 3772d9f23668607881beb38a463bea3fe3a13059e48ce132fbb21508237b6f1d005e4e674716da76f31de1ac5ec4c24a922273e9d60f4e18fcdeccd2e8d30787
+MISC metadata.xml 339 BLAKE2B ee77cccbd6cbd65ca83cbca745047dd8ee4d0ec6e955cbc2238b0d403c9c65815ceda7737f70f05a6f01305639b13cb339509a03a7ccf93cde1c643850cc8472 SHA512 1d76e3ee88423ffcc2902c658e434afc2d6a42464f98a651a563441b76d5a236072f4324d7a2f7fe67e6061c6d4ae9cee00af26e1e7519d4ac428e07f11d3c03
diff --git a/dev-ruby/tty-command/metadata.xml b/dev-ruby/tty-command/metadata.xml
new file mode 100644
index 000000000000..9be0b27e3e08
--- /dev/null
+++ b/dev-ruby/tty-command/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">piotrmurach/tty-command</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/tty-command/tty-command-0.8.2.ebuild b/dev-ruby/tty-command/tty-command-0.8.2.ebuild
new file mode 100644
index 000000000000..3bb1808e5d9c
--- /dev/null
+++ b/dev-ruby/tty-command/tty-command-0.8.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Terminal color capabilities detection"
+HOMEPAGE="https://github.com/piotrmurach/tty-command"
+SRC_URI="https://github.com/piotrmurach/tty-command/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "=dev-ruby/pastel-0.7*"
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+}