summaryrefslogtreecommitdiff
path: root/dev-ruby/tty-command
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-ruby/tty-command
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-ruby/tty-command')
-rw-r--r--dev-ruby/tty-command/Manifest1
-rw-r--r--dev-ruby/tty-command/tty-command-0.10.1-r1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/tty-command/Manifest b/dev-ruby/tty-command/Manifest
index 3dd11c46892e..64789a91a65d 100644
--- a/dev-ruby/tty-command/Manifest
+++ b/dev-ruby/tty-command/Manifest
@@ -1,3 +1,4 @@
DIST tty-command-0.10.1.tar.gz 32359 BLAKE2B 85dd115d113abda7464f1d6935a730c97c312bcd280c16bbff44f5da294ed9197df2615449656ce8d403b4118c6d363710eb32e49a2ebb3c75896f5feda85bce SHA512 aa707f3af6b72f20ea692469c7dc60bbf146bc59eaedf4a57408a463e7f96b48dc9ec60de31f2298e36b6d56320b238b4364ee0f90d1499784d001e963ea6fa1
+EBUILD tty-command-0.10.1-r1.ebuild 717 BLAKE2B 1779e336afe20686fdae08c6a0f2b64a031cd9d4c43b9b7e16725f1f426088eff483ad3d8eb447e6751ebeba65caedefd737f224f736bac4d4917caf2502dec3 SHA512 545ec5790e74e57c5cad6de6de44afcf12c568e833eb5617ff693a265badbf686caa805d3aafece3356a59937fc608d0986111439276df5b4bafdd45313ffbf0
EBUILD tty-command-0.10.1.ebuild 717 BLAKE2B 49546179989a39d53aadff5a809fcc49652876dc5267cb4167ae5f6a6d983ccfeca1969e40e19053e4a20f68db69310b5b260e7b1015c8bf3d95a15bd547fbd1 SHA512 fa1aace5caf0643f4ebb6d18b87de33351881d895ab9b85e952f9195f207d0169268ded5407c7d799c268328c98a00881894189a5440e8cbc7ee1488fcfb7d97
MISC metadata.xml 340 BLAKE2B 5f0adfc79c3fd86851c191ba3b6e1d818fd6cea8bf7a8ecab90ccd95890c75e564d36be98cee39f4fc031727f448f6b4894ede1a0b8af3ac6872c2391bf6a2a1 SHA512 8d25f4c8c82d6a637a4e68052df77e86e86f37fdb1691570394df5e289fe977b2602e0b0fb7cfd37ec5459262922c6a4b2003a24de29fd13c4893a63a04127fb
diff --git a/dev-ruby/tty-command/tty-command-0.10.1-r1.ebuild b/dev-ruby/tty-command/tty-command-0.10.1-r1.ebuild
new file mode 100644
index 000000000000..3149701958af
--- /dev/null
+++ b/dev-ruby/tty-command/tty-command-0.10.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Terminal color capabilities detection"
+HOMEPAGE="https://github.com/piotrmurach/tty-command"
+SRC_URI="https://github.com/piotrmurach/tty-command/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/pastel-0.8:0"
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}