summaryrefslogtreecommitdiff
path: root/dev-ruby/ttfunk/ttfunk-1.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-ruby/ttfunk/ttfunk-1.7.0.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-ruby/ttfunk/ttfunk-1.7.0.ebuild')
-rw-r--r--dev-ruby/ttfunk/ttfunk-1.7.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/ttfunk/ttfunk-1.7.0.ebuild b/dev-ruby/ttfunk/ttfunk-1.7.0.ebuild
new file mode 100644
index 000000000000..b45a8db23a4b
--- /dev/null
+++ b/dev-ruby/ttfunk/ttfunk-1.7.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="ttfunk.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A TrueType font parser written in pure ruby"
+HOMEPAGE="https://github.com/prawnpdf/ttfunk/"
+SRC_URI="https://github.com/prawnpdf/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 Ruby )"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' spec/spec_helper.rb || die
+}