summaryrefslogtreecommitdiff
path: root/dev-ruby/tidy_table/tidy_table-0.0.5-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/tidy_table/tidy_table-0.0.5-r4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/tidy_table/tidy_table-0.0.5-r4.ebuild')
-rw-r--r--dev-ruby/tidy_table/tidy_table-0.0.5-r4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/tidy_table/tidy_table-0.0.5-r4.ebuild b/dev-ruby/tidy_table/tidy_table-0.0.5-r4.ebuild
new file mode 100644
index 000000000000..c39962905beb
--- /dev/null
+++ b/dev-ruby/tidy_table/tidy_table-0.0.5-r4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Tool to convert an array of struct into an HTML table"
+HOMEPAGE="https://github.com/topfunky/tidy_table"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Remove reference to RSpec 1
+ sed -i -e '/spec/d' spec/spec_helper.rb || die
+}