summaryrefslogtreecommitdiff
path: root/dev-ruby/thread_safe/thread_safe-0.3.6-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-18 17:39:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-18 17:39:04 +0000
commit9897403e8218123dc1c8d3797b083652f08779a9 (patch)
tree4094b584adf5bb6134895d92d675388b79bc13a0 /dev-ruby/thread_safe/thread_safe-0.3.6-r3.ebuild
parent08f1ae6b8bd1202a10c5f0d07ee0adc846e0308c (diff)
gentoo auto-resync : 18:02:2024 - 17:39:04
Diffstat (limited to 'dev-ruby/thread_safe/thread_safe-0.3.6-r3.ebuild')
-rw-r--r--dev-ruby/thread_safe/thread_safe-0.3.6-r3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/thread_safe/thread_safe-0.3.6-r3.ebuild b/dev-ruby/thread_safe/thread_safe-0.3.6-r3.ebuild
new file mode 100644
index 000000000000..5c1fc6d1c363
--- /dev/null
+++ b/dev-ruby/thread_safe/thread_safe-0.3.6-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A collection of thread-safe versions of common core Ruby classes"
+HOMEPAGE="https://github.com/ruby-concurrency/thread_safe"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+
+each_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e '/coveralls/I s:^:#:' \
+ -e '/simplecov/ s:^:#:' \
+ -e '/SimpleCov/,/^end/ s:^:#:' spec/spec_helper.rb || die
+}
+
+each_ruby_test() {
+ einfo "The test suite may take up to 10 minutes to run without apparent feedback"
+ each_fakegem_test
+}