summaryrefslogtreecommitdiff
path: root/dev-ruby/thread_order/thread_order-1.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /dev-ruby/thread_order/thread_order-1.1.1.ebuild
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'dev-ruby/thread_order/thread_order-1.1.1.ebuild')
-rw-r--r--dev-ruby/thread_order/thread_order-1.1.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/thread_order/thread_order-1.1.1.ebuild b/dev-ruby/thread_order/thread_order-1.1.1.ebuild
new file mode 100644
index 000000000000..2508265e0f6f
--- /dev/null
+++ b/dev-ruby/thread_order/thread_order-1.1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="Readme.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Test helper for ordering threaded code"
+HOMEPAGE="https://github.com/JoshCheek/thread_order"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ # Avoid failing spec that already has exceptions for some ruby
+ # implementations and is not essential.
+ sed -i -e '/depending on the stdlib/,/^ end/ s:^:#:' \
+ spec/thread_order_spec.rb || die
+}