summaryrefslogtreecommitdiff
path: root/dev-ruby/textpow/textpow-1.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/textpow/textpow-1.4.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/textpow/textpow-1.4.0.ebuild')
-rw-r--r--dev-ruby/textpow/textpow-1.4.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/textpow/textpow-1.4.0.ebuild b/dev-ruby/textpow/textpow-1.4.0.ebuild
new file mode 100644
index 000000000000..94931ad65178
--- /dev/null
+++ b/dev-ruby/textpow/textpow-1.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/grosser/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="A library to parse and process Textmate bundles"
+HOMEPAGE="http://textpow.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/plist-3.0.1"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' textpow.gemspec || die
+}