summaryrefslogtreecommitdiff
path: root/dev-ruby/text-hyphen/text-hyphen-1.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-19 12:34:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-19 12:34:34 +0000
commit1d300fd75dc60cab2ca6e0bb0016b09a4fb7c67a (patch)
tree5dff362f093f67da764ce10a380ad9d14646b46e /dev-ruby/text-hyphen/text-hyphen-1.5.0.ebuild
parent78634f348a30a55cc55606ee1ecde032241ceaeb (diff)
gentoo auto-resync : 19:03:2023 - 12:34:33
Diffstat (limited to 'dev-ruby/text-hyphen/text-hyphen-1.5.0.ebuild')
-rw-r--r--dev-ruby/text-hyphen/text-hyphen-1.5.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/text-hyphen/text-hyphen-1.5.0.ebuild b/dev-ruby/text-hyphen/text-hyphen-1.5.0.ebuild
new file mode 100644
index 000000000000..f19b311a4a1b
--- /dev/null
+++ b/dev-ruby/text-hyphen/text-hyphen-1.5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.md History.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hyphenates words according to the rules of the language the word is written in"
+HOMEPAGE="https://rubygems.org/gems/text-hyphen"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/hoe-2.8.0
+ dev-ruby/test-unit:2
+ )"
+
+all_ruby_prepare() {
+ sed -i -e '2igem "test-unit", ">= 2.0"' test/test_*.rb || die
+}