summaryrefslogtreecommitdiff
path: root/dev-ruby/text-hyphen/text-hyphen-1.4.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/text-hyphen/text-hyphen-1.4.1-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/text-hyphen/text-hyphen-1.4.1-r2.ebuild')
-rw-r--r--dev-ruby/text-hyphen/text-hyphen-1.4.1-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/text-hyphen/text-hyphen-1.4.1-r2.ebuild b/dev-ruby/text-hyphen/text-hyphen-1.4.1-r2.ebuild
new file mode 100644
index 000000000000..78164eece2a6
--- /dev/null
+++ b/dev-ruby/text-hyphen/text-hyphen-1.4.1-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hyphenates words according to the rules of the language the word is written in"
+HOMEPAGE="http://rubyforge.org/projects/text-format"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/hoe-2.8.0
+ dev-ruby/test-unit:2
+ )"
+
+all_ruby_prepare() {
+ sed -i -e '2igem "test-unit", ">= 2.0"' test/test_*.rb || die
+}