summaryrefslogtreecommitdiff
path: root/dev-ruby/text-hyphen/text-hyphen-1.4.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/text-hyphen/text-hyphen-1.4.1-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/text-hyphen/text-hyphen-1.4.1-r2.ebuild')
-rw-r--r--dev-ruby/text-hyphen/text-hyphen-1.4.1-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/text-hyphen/text-hyphen-1.4.1-r2.ebuild b/dev-ruby/text-hyphen/text-hyphen-1.4.1-r2.ebuild
new file mode 100644
index 000000000000..944872608d10
--- /dev/null
+++ b/dev-ruby/text-hyphen/text-hyphen-1.4.1-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hyphenates words according to the rules of the language the word is written in"
+HOMEPAGE="http://rubyforge.org/projects/text-format"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? (
+ >=dev-ruby/hoe-2.8.0
+ )
+ test? (
+ >=dev-ruby/hoe-2.8.0
+ dev-ruby/test-unit:2
+ )"
+
+all_ruby_prepare() {
+ sed -i -e '2igem "test-unit", ">= 2.0"' test/test_*.rb || die
+}