summaryrefslogtreecommitdiff
path: root/dev-ruby/test_construct
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
commit2018227e9344edb9da15fc6a4a8298086cc2aa77 (patch)
treec18e1c09e605e94e2a1e93345ad25746cc9e14b9 /dev-ruby/test_construct
parent6f8038813c460b4f0572d5ef595cdfa94af3a94d (diff)
gentoo resync : 02.06.2019
Diffstat (limited to 'dev-ruby/test_construct')
-rw-r--r--dev-ruby/test_construct/Manifest2
-rw-r--r--dev-ruby/test_construct/test_construct-2.0.2.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/test_construct/Manifest b/dev-ruby/test_construct/Manifest
index 6f918e4d04cf..21fae8f17058 100644
--- a/dev-ruby/test_construct/Manifest
+++ b/dev-ruby/test_construct/Manifest
@@ -1,3 +1,5 @@
DIST test_construct-2.0.1.gem 13312 BLAKE2B cda8bec1e1fe343ae506c73bf480a982fdd1224da1e77ab19827a3b76dba57294397d811040448cef6956c8492c9c5cb618d204834d31b54e8619b3d224da20c SHA512 c9898beb04d23974dc5b66a9d7bb4a77cd040cc63b724108c4fc4b81f0680d23a9e09b96110c1b5458107d0c2c8714cbed8b2e81611eef8ca7fab92b31014e98
+DIST test_construct-2.0.2.gem 13312 BLAKE2B e1a5068e8133f739dfc407e943b0486c0c2bb2a8f18943a23b366205b206a56b792630daad7a92a021ea367d490b117aec1313faa0e5360bf6b984df3b82c16c SHA512 d73e2daf5c5974c79aedfcd7e1cd6681a3f1f6fe3f2c68bcde26690a18be920ea53b648407e4ee33444364b2a02f1517362c876e703abad02fc528a47de092ff
EBUILD test_construct-2.0.1-r1.ebuild 605 BLAKE2B e196f6c66397ede5b6ac53867d11f51a341eda3a1a9851e4431234cd6b14089b9611ca28741af2d465a1b99c73cf16cd76b5a8be55c5a796ae9febb42c0a5dc7 SHA512 16fafa0e0090a2fb076715008b2c466515cb48bf548404e9635a2fc6e1d31a18008414ba1ab1a5bfec0a845ba8fb53f7d251f8b1a8ba58371fd3aaa6ecd5007c
+EBUILD test_construct-2.0.2.ebuild 598 BLAKE2B 44b65fe864a73e394d14ef583bad03815971df4dec8c0853fede1251a8be66c7356605aa9420a3697a51d240aa135d21c507868a8bc570016de08bfb9d3ea8e4 SHA512 c65c2c2a6246b1b47669b07d45eb1d2b48f60b55ebc12b995911534eb8290a81141bcc4093929e79e9a416059fc40526d0b04fe75e73a7a326323227e520c882
MISC metadata.xml 344 BLAKE2B 57f981c2fc03d23ec6e61d5eed8c83a647e6e01273fe5c8d30bc3aeb2ad206e47cf11a4febea9f5fb4af1c4f112ad5d90e30d6669b9d77bb16fe939ab305a9e3 SHA512 a22764193d618f851e61007e23776099d89f6f81345326ca65916671ce532a0de0ca7bfe0714903ca004d19b876975b9d005980336731babea75d6e711fa9199
diff --git a/dev-ruby/test_construct/test_construct-2.0.2.ebuild b/dev-ruby/test_construct/test_construct-2.0.2.ebuild
new file mode 100644
index 000000000000..dd4b939f5a67
--- /dev/null
+++ b/dev-ruby/test_construct/test_construct-2.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Creates temporary files and directories for testing"
+HOMEPAGE="https://github.com/bhb/test_construct"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/minitest-5.0.8
+ >=dev-ruby/mocha-0.14.0
+ dev-ruby/rspec:3
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+}