summaryrefslogtreecommitdiff
path: root/dev-ruby/termcolor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/termcolor
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/termcolor')
-rw-r--r--dev-ruby/termcolor/Manifest3
-rw-r--r--dev-ruby/termcolor/metadata.xml11
-rw-r--r--dev-ruby/termcolor/termcolor-1.2.2.ebuild24
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/termcolor/Manifest b/dev-ruby/termcolor/Manifest
new file mode 100644
index 000000000000..ec89ecbd5d96
--- /dev/null
+++ b/dev-ruby/termcolor/Manifest
@@ -0,0 +1,3 @@
+DIST termcolor-1.2.2.gem 7168 BLAKE2B 6627de8edebe771d3472448e006fcebae201c7d06524b173a47db50ed253c19c1b54a38784cd4f9f1252d9355e5d779e89d023c03aed36332874f9b80b030991 SHA512 1709c6ce299a320209288cc27fb1e8f80492e582b84be2e54f3a09b96c1d2e048760b8f72e19581bd8bc6c1539c34ac010cb3e7bec4a7c24909eff438639182e
+EBUILD termcolor-1.2.2.ebuild 604 BLAKE2B c6f073e6cfd2455e6410152d8954b4248d11b8540befaa5c454e273ad9b7b18acc8dc19b0ab89313f13bb3983b0de6e234b99360ef394fecbb460fdd82c9a82f SHA512 88aff6cbc39d9067209a6a003aa21c7818f7d72276eba4688eaf7488e4c1257a4a4bcb46307255bb91b7c32cc40bacdbf13f5a7031570bd9ac87cd5d0c59b7ed
+MISC metadata.xml 336 BLAKE2B 25d3167e6beba8398b365c9a0eacc292d5d868aef252be7029e665919d862e1449c28bb8659ee46308f259c0cb1d89fcf1184fc4cf9e6f53f8c2bd4ac8ba00ab SHA512 a5601ee0d584d47b1b6feefdb119bd2030a48a4106774296f8a02bd6ee4baf3375ea2c90acbfb7b5a7b36c4228f0123be7cd9de386dadce50b08457e947bf4ba
diff --git a/dev-ruby/termcolor/metadata.xml b/dev-ruby/termcolor/metadata.xml
new file mode 100644
index 000000000000..7d3fa9eaac59
--- /dev/null
+++ b/dev-ruby/termcolor/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>naota@gentoo.org</email>
+ </maintainer>
+<maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-ruby/termcolor/termcolor-1.2.2.ebuild b/dev-ruby/termcolor/termcolor-1.2.2.ebuild
new file mode 100644
index 000000000000..568e067cd5a0
--- /dev/null
+++ b/dev-ruby/termcolor/termcolor-1.2.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+#*** Using highline effectively in JRuby requires manually installing the ffi-ncurses gem.
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="a library for ANSI color formatting like HTML for output in terminal"
+HOMEPAGE="http://termcolor.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/highline-1.5.0"