summaryrefslogtreecommitdiff
path: root/dev-ruby/temple/temple-0.8.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /dev-ruby/temple/temple-0.8.2-r1.ebuild
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'dev-ruby/temple/temple-0.8.2-r1.ebuild')
-rw-r--r--dev-ruby/temple/temple-0.8.2-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/temple/temple-0.8.2-r1.ebuild b/dev-ruby/temple/temple-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..9a7616a68d2b
--- /dev/null
+++ b/dev-ruby/temple/temple-0.8.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES EXPRESSIONS.md README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="An abstraction and a framework for compiling templates to pure Ruby"
+HOMEPAGE="https://github.com/judofyr/temple"
+
+LICENSE="MIT"
+SLOT="0.7"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/bacon
+ dev-ruby/erubis
+ >=dev-ruby/tilt-2.0.1 )"
+
+each_ruby_test() {
+ ${RUBY} -S bacon -Ilib -Itest --automatic --quiet || die
+}